UVA11997:K Smallest Sums(多路归并求最小k个和)

You’re given k arrays, each array has k integers. There are k
k ways to pick exactly one element in each
array and calculate the sum of the integers. Your task is to find the k smallest sums among them.
Input
There will be several test cases. The first line of each case contains an integer k (2 k 750). Each of
the following k lines contains k positive integers in each array. Each of these integers does not exceed
1,000,000. The input is terminated by end-of-file (EOF).
Output
For each test case, print the k smallest sums, in ascending order.
Sample Input
3
1 8 5
9 2 5
10 7 6
2
1 1
1 2
Sample Output
9 10 12

2 2


题意:

n个数组,每个数组选一个数,会产生很n^n个和,要求输出n个最小的和


思路:

首先对于n=2的状况,两个数组为a,b

那么我们对于每个a可以得到

1:a[1]+b[1]<=a[1]+b[2]<=...<=a[1]+b[n]

.

.

.

n:a[n]+b[1]<=a[n]+b[2]<=...<=a[n]+b[n]


对于第k个表得到a[k]+b[k],我们使用二元组(S,B)表示一个元素,其中S=a[k]+b[k],B是b的下标

a的下标不用记录,因为对于下一个二元组(S',B+1),有S‘=a[k]+b[k+1]=S-b[k]+b[k+1]

不过本题有n个表,我们可以通过两两合并就可以得出答案


#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stack>
#include <queue>
#include <map>
#include <set>
#include <vector>
#include <math.h>
#include <bitset>
#include <algorithm>
#include <climits>
using namespace std;

#define LS 2*i
#define RS 2*i+1
#define UP(i,x,y) for(i=x;i<=y;i++)
#define DOWN(i,x,y) for(i=x;i>=y;i--)
#define MEM(a,x) memset(a,x,sizeof(a))
#define W(a) while(a)
#define gcd(a,b) __gcd(a,b)
#define LL long long
#define N 100005
#define MOD 1000000007
#define INF 0x3f3f3f3f
#define EXP 1e-8

int a[755][755];

struct node
{
    int s,b;
    node(int _s,int _b):s(_s),b(_b) {}
    bool operator< (node a)const
    {
        return a.s<s;
    }
};

void merge(int *a,int *b,int *c,int n)
{
    int i,j,k;
    priority_queue<node> Q;
    for(i = 0;i<n;i++)
    Q.push(node(a[i]+b[0],0));

    for(i = 0;i<n;i++)//只取最小的n个
    {
        node r = Q.top();
        Q.pop();
        c[i] = r.s;
        int i = r.b;
        if(i+1<n)
        {
            Q.push(node(r.s-b[i]+b[i+1],i+1));
        }
    }
}

int main()
{
    int n,i,j,k;
    while(~scanf("%d",&n))
    {
        for(i = 0; i<n; i++)
        {
            for(j = 0; j<n; j++)
                scanf("%d",&a[i][j]);
            sort(a[i],a[i]+n);
        }

        for(i = 1;i<n;i++)
        merge(a[0],a[i],a[0],n);

        printf("%d",a[0][0]);
        for(i = 1;i<n;i++)
        printf(" %d",a[0][i]);
        printf("\n");
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值