HDU1061:Rightmost Digit

Problem Description
Given a positive integer N, you should output the most right digit of N^N.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single positive integer N(1<=N<=1,000,000,000).
 

Output
For each test case, you should output the rightmost digit of N^N.
 

Sample Input
  
  
2 3 4
 

Sample Output
  
  
7 6
Hint
In the first case, 3 * 3 * 3 = 27, so the rightmost digit is 7. In the second case, 4 * 4 * 4 * 4 = 256, so the rightmost digit is 6.
 


 

//这道题与HDU1097题基本就是一样的

只需要稍微改一下就可以了

 

#include <stdio.h>
#include<string.h>
int main()
{
    int a,b,n,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&a);
        n=a%10;
        b = a;
        if(b==0)
            printf("1\n");
        else
        {
            switch(n)
            {
            case 0:
            case 1:
            case 6:
                break;
            case 2:
                n=b%4;
                switch(n)
                {
                case 1:
                    n=2;
                    break;
                case 2:
                    n=4;
                    break;
                case 3:
                    n=8;
                    break;
                case 0:
                    n=6;
                    break;
                }
                break;
            case 3:
                n=b%4;
                switch(n)
                {
                case 1:
                    n=3;
                    break;
                case 2:
                    n=9;
                    break;
                case 3:
                    n=7;
                    break;
                case 0:
                    n=1;
                    break;
                }
                break;
            case 4:
                n=b%2;
                switch(n)
                {
                case 1:
                    n=4;
                    break;
                case 0:
                    n=6;
                    break;
                }
                break;
            case 7:
                n=b%4;
                switch(n)
                {
                case 1:
                    n=7;
                    break;
                case 2:
                    n=9;
                    break;
                case 3:
                    n=3;
                    break;
                case 0:
                    n=1;
                    break;
                }
                break;
            case 8:
                n=b%4;
                switch(n)
                {
                case 1:
                    n=8;
                    break;
                case 2:
                    n=4;
                    break;
                case 3:
                    n=2;
                    break;
                case 0:
                    n=6;
                    break;
                }
                break;
            case 9:
                n=b%2;
                switch(n)
                {
                case 1:
                    n=9;
                    break;
                case 0:
                    n=1;
                    break;
                }
                break;
            }
        }
        printf("%d\n",n);
    }
    return 0;
}


 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值