HDU1302:The Snail

Problem Description
A snail is at the bottom of a 6-foot well and wants to climb to the top. The snail can climb 3 feet while the sun is up, but slides down 1 foot at night while sleeping. The snail has a fatigue factor of 10%, which means that on each successive day the snail climbs 10% * 3 = 0.3 feet less than it did the previous day. (The distance lost to fatigue is always 10% of the first day's climbing distance.) On what day does the snail leave the well, i.e., what is the first day during which the snail's height exceeds 6 feet? (A day consists of a period of sunlight followed by a period of darkness.) As you can see from the following table, the snail leaves the well during the third day.  

Day Initial Height Distance Climbed Height After Climbing Height After Sliding  
1 0 3 3 2  
2 2 2.7 4.7 3.7  
3 3.7 2.4 6.1 -  

Your job is to solve this problem in general. Depending on the parameters of the problem, the snail will eventually either leave the well or slide back to the bottom of the well. (In other words, the snail's height will exceed the height of the well or become negative.) You must find out which happens first and on what day.
 

Input
The input file contains one or more test cases, each on a line by itself. Each line contains four integers H, U, D, and F, separated by a single space. If H = 0 it signals the end of the input; otherwise, all four numbers will be between 1 and 100, inclusive. H is the height of the well in feet, U is the distance in feet that the snail can climb during the day, D is the distance in feet that the snail slides down during the night, and F is the fatigue factor expressed as a percentage. The snail never climbs a negative distance. If the fatigue factor drops the snail's climbing distance below zero, the snail does not climb at all that day. Regardless of how far the snail climbed, it always slides D feet at night.
 

Output
For each test case, output a line indicating whether the snail succeeded (left the well) or failed (slid back to the bottom) and on what day. Format the output exactly as shown in the example.
 

Sample Input
  
  
6 3 1 10 10 2 1 50 50 5 3 14 50 6 4 1 50 6 3 1 1 1 1 1 0 0 0 0
 

Sample Output
  
  
success on day 3 failure on day 4 failure on day 7 failure on day 68 success on day 20 failure on day 2
 


 

简单模拟题

意思就是给四个数字

H-总高

U-初始速度

D-下滑距离

F-速度下降的概率

先计算出每次速度下降的大小为U*F

然后统计出天数,当天起点高度,爬升距离,爬升后的高度,下滑后的高度

然后下滑后的高度小于0就失败

爬升后的高度大于总高度就成功

代码实现如下

#include <stdio.h>

int main()
{
    double h,u,d,f;
    double start_h,pa_h,sum_h,xiahua_h,t;
    int day = 0;
    /*
    start_h:开始速度
    pa_h:此次爬升高度
    sum_h:没下滑时的高度
    xiahua_h:下滑后的高度
    */
    while(~scanf("%lf%lf%lf%lf",&h,&u,&d,&f))
    {
        if(!h)
        break;
        f = f/100;
        t = u*f;
        start_h = pa_h = sum_h = xiahua_h = 0;
        day = 0;
        int flag = 1;
        while(sum_h<=h)
        {
            pa_h = u;
            sum_h = start_h + pa_h;;
            xiahua_h = sum_h-d;
            start_h = xiahua_h;
            u-=t;
            if(u<=0)
            {
                u = 0;
                t = 0;
            }
            day++;
            if(xiahua_h<0)
            {
                flag = 0;
                break;
            }
        }
        if(flag)
        printf("success on day %d\n",day);
        else
        printf("failure on day %d\n",day);
    }

    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值