HDU3345:War Chess(BFS+优先队列)

Problem Description
War chess is hh's favorite game:
In this game, there is an N * M battle map, and every player has his own Moving Val (MV). In each round, every player can move in four directions as long as he has enough MV. To simplify the problem, you are given your position and asked to output which grids you can arrive.

In the map:
'Y' is your current position (there is one and only one Y in the given map).
'.' is a normal grid. It costs you 1 MV to enter in this gird.
'T' is a tree. It costs you 2 MV to enter in this gird.
'R' is a river. It costs you 3 MV to enter in this gird.
'#' is an obstacle. You can never enter in this gird.
'E's are your enemies. You cannot move across your enemy, because once you enter the grids which are adjacent with 'E', you will lose all your MV. Here “adjacent” means two grids share a common edge.
'P's are your partners. You can move across your partner, but you cannot stay in the same grid with him final, because there can only be one person in one grid.You can assume the Ps must stand on '.' . so ,it also costs you 1 MV to enter this grid.
 

Input
The first line of the inputs is T, which stands for the number of test cases you need to solve.
Then T cases follow:
Each test case starts with a line contains three numbers N,M and MV (2<= N , M <=100,0<=MV<= 65536) which indicate the size of the map and Y's MV.Then a N*M two-dimensional array follows, which describe the whole map.
 

Output
Output the N*M map, using '*'s to replace all the grids 'Y' can arrive (except the 'Y' grid itself). Output a blank line after each case.
 

Sample Input
  
  
5 3 3 100 ... .E. ..Y 5 6 4 ...... ....PR ..E.PY ...ETT ....TT 2 2 100 .E EY 5 5 2 ..... ..P.. .PYP. ..P.. ..... 3 3 1 .E. EYE ...
 

Sample Output
  
  
... .E* .*Y ...*** ..**P* ..E*PY ...E** ....T* .E EY ..*.. .*P*. *PYP* .*P*. ..*.. .E. EYE .*.
 


 

题意:Y为起始点,MV为移动能量,经过同伴和空地消耗一点能量,经过森林消耗两点,小河三点,如果旁边四格有敌人,能量变为0,而且不能停留在同伴所在的格子,最后输出时将所有能停留的格子变为*

思路:直接BFS,然后按情况分类即可

 

#include <stdio.h>
#include <string.h>
#include <queue>
using namespace std;

char map[105][105];
int n,m,mv;
int vis[105][105];
int sx,sy;
int to[4][2] = {1,0,-1,0,0,1,0,-1};

struct node
{
    int x,y,mv;
    friend bool operator<(node n1,node n2)
    {
        return n1.mv<n2.mv;
    }

};


int check(int x,int y)//判断出界
{
    if(x<0 || y<0 || x>=n || y>=m)
        return 1;
    return 0;
}

int judge(int x,int y)//判断临近是否有敌人
{
    if(!check(x-1,y) && map[x-1][y] == 'E')
        return 1;
    if(!check(x+1,y) && map[x+1][y] == 'E')
        return 1;
    if(!check(x,y-1) && map[x][y-1] == 'E')
        return 1;
    if(!check(x,y+1) && map[x][y+1] == 'E')
        return 1;
    return 0;
}

void bfs()
{
    int i,j;
    priority_queue<node> Q;
    node a,next;
    memset(vis,0,sizeof(vis));
    a.x = sx;
    a.y = sy;
    a.mv = mv;
    vis[sx][sy] = 1;
    Q.push(a);
    while(!Q.empty())
    {
        a = Q.top();
        Q.pop();
        if(a.mv<=0)
            continue;
        for(i = 0; i<4; i++)
        {
            next = a;
            next.x+=to[i][0];
            next.y+=to[i][1];
            if(check(next.x,next.y) || vis[next.x][next.y] || map[next.x][next.y] == '#' || map[next.x][next.y] == 'E')
                continue;
            if(map[next.x][next.y] == '.') next.mv--;
            else if(map[next.x][next.y] == 'T') next.mv-=2;
            else if(map[next.x][next.y] == 'R') next.mv-=3;
            else if(map[next.x][next.y] == 'P') next.mv--;
            if(next.mv<0)//能量不足以走到此处则返回
                continue;
            if(judge(next.x,next.y))//有敌人则能量变为0
                next.mv = 0;
            Q.push(next);
            vis[next.x][next.y] =1;
            if(map[next.x][next.y] != 'P')//处同伴外停留的地方变为*
                map[next.x][next.y] = '*';
        }
    }
}

int main()
{
    int t;
    int i,j;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&mv);
        for(i = 0; i<n; i++)
        {
            scanf("%s",map[i]);
            for(j = 0; map[i][j]; j++)
            {
                if(map[i][j] == 'Y')
                {
                    sx = i;
                    sy = j;
                }
            }
        }
        bfs();
        for(i = 0; i<n; i++)
            printf("%s\n",map[i]);
        printf("\n");
    }

    return 0;
}


 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值