HDU4144:Bacon's Cipher

Problem Description
Bacon's cipher or the Baconian cipher is a method of steganography (a method of hiding a secret message as opposed to a true cipher) devised by Francis Bacon. A message is concealed in the presentation of text, rather than its content.  
As we all know, each letter has its position in the alphabet, ‘A’ is 0, ‘B’ is 1, ‘C’ is 2…and so on. And each number can be represented in binary code, for example, 2 is ‘10’ in binary system. Then we expand the binary code to five digits by adding leading zeros, then 10 becomes 00010. Now we can use this number to encode. To simplify the question, we define the rules as below:
0 corresponds to a random uppercase letter and 1 corresponds to a random number, so after encoding, 00010 ( ‘C’ ) is transformed to ABC1D or JUG9N.  
To decode, do the opposite way around.
 

Input
The first line contains a positive number l, represents the length of the encoded string. L<=10000 and can be divided by 5. The second line is the encoded string.
 

Output
The original string.
 

Sample Input
  
  
35 ON1E2H5Q39AK2TGIC9ERT39B2P423L8B20D
 

Sample Output
  
  
FLEENOW
 


 

题意:给出一串密码,字母代表0,数字代表1,每五个构成一个二进制,该二进制的值代表一个字母,求出明文

思路:水题,最近忙于考试,先A道水题来找找感觉

 

#include <stdio.h>
#include <string.h>

int num(char c)
{
    if(c>='A' && c<='Z')
    return 0;
    else return 1;
}

int main()
{
    int n,i,k;
    char a[10005];
    while(~scanf("%d%s",&n,a))
    {
        for(i = 0;i<n;i+=5)
        {
            k = 0;
            if(num(a[i]))
            k+=16;
            if(num(a[i+1]))
            k+=8;
            if(num(a[i+2]))
            k+=4;
            if(num(a[i+3]))
            k+=2;
            if(num(a[i+4]))
            k++;
            printf("%c",k+'A');
        }
        printf("\n");
    }

    return 0;
}


 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值