NBUT1477:AmeriDarts

http://ac.nbutoj.com/Problem/view.xhtml?id=1477

  • 问题描述
  • AmeriDarts is a dangerous but full of glamour. Mr.cai wants to have a try.
    The rule is simple:throw some boomerangs in a line from left to right as quickly as you can. You are asked to throw twice, first time throw A red boomerangs, second time throw B blue boomerangs. Your score is to calculate the shortest length of blue and red boomerang. This rule seems strange? so am I.
  • 输入
  • First there is two integer A(no more than 1000) and B(no more than 1000), then followed two lines consist of those A and B numbers.Note that these two array both in ascending order.
  • 输出
  • For each testcase, output the shortest length between red and blue boomerang in a single line.
  • 样例输入
  • 4 4
    1 2 3 4
    5 6 7 8
    5 5
    5 12 14 15 16
    1 2 7 8 9
    
  • 样例输出
  • 12

     

    题意:找出两个数组中数字差距最小的距离

    思路:由于数组是递增的,所以只要记录b数组比较到了那个数即可,无需回溯

     

    #include <stdio.h>
    #include <algorithm>
    using namespace std;
    
    int jian(int a,int b)
    {
        int k = a-b;
        if(k<0)
        return -k;
        return k;
    }
    
    int main()
    {
        int n,m,i,j,l,t;
        int a[1005],b[1005],c[1005];
        while(~scanf("%d%d",&n,&m))
        {
            l = 0;
            for(i = 1;i<=n;i++)
            scanf("%d",&a[i]);
            for(i = 1;i<=m;i++)
            scanf("%d",&b[i]);
            b[0] = 0;
            b[m+1] = 0;
            t = 1;
            for(i = 1;i<=n;i++)
            {
                for(j = t;j<=m;j++)
                {
                    if(jian(a[i],b[j])<jian(a[i],b[j-1]) && jian(a[i],b[j])<jian(a[i],b[j+1]))//找到差距最小的地方
                    {
                        t = j;//记录b数组所到的位置,放置回溯,节约时间
                        c[l++] = jian(a[i],b[j]);
                    }
                }
            }
            sort(c,c+l);
            printf("%d\n",c[0]);
        }
    
        return 0;
    }
    


     

Stkcd [股票代码] ShortName [股票简称] Accper [统计截止日期] Typrep [报表类型编码] Indcd [行业代码] Indnme [行业名称] Source [公告来源] F060101B [净利润现金净含量] F060101C [净利润现金净含量TTM] F060201B [营业收入现金含量] F060201C [营业收入现金含量TTM] F060301B [营业收入现金净含量] F060301C [营业收入现金净含量TTM] F060401B [营业利润现金净含量] F060401C [营业利润现金净含量TTM] F060901B [筹资活动债权人现金净流量] F060901C [筹资活动债权人现金净流量TTM] F061001B [筹资活动股东现金净流量] F061001C [筹资活动股东现金净流量TTM] F061201B [折旧摊销] F061201C [折旧摊销TTM] F061301B [公司现金流1] F061302B [公司现金流2] F061301C [公司现金流TTM1] F061302C [公司现金流TTM2] F061401B [股权现金流1] F061402B [股权现金流2] F061401C [股权现金流TTM1] F061402C [股权现金流TTM2] F061501B [公司自由现金流(原有)] F061601B [股权自由现金流(原有)] F061701B [全部现金回收率] F061801B [营运指数] F061901B [资本支出与折旧摊销比] F062001B [现金适合比率] F062101B [现金再投资比率] F062201B [现金满足投资比率] F062301B [股权自由现金流] F062401B [企业自由现金流] Indcd1 [行业代码1] Indnme1 [行业名称1] 季度数据,所有沪深北上市公司的 分别包含excel、dta数据文件格式及其说明,便于不同软件工具对数据的分析应用 数据来源:基于上市公司年报及公告数据整理,或相关证券交易所、各部委、省、市数据 数据范围:基于沪深北证上市公司 A股(主板、中小企业板、创业板、科创板等)数据整理计算
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值