POJ1655:Balancing Act(树形DP)

Description

Consider a tree T with N (1 <= N <= 20,000) nodes numbered 1...N. Deleting any node from the tree yields a forest: a collection of one or more trees. Define the balance of a node to be the size of the largest tree in the forest T created by deleting that node from T.
For example, consider the tree:

Deleting node 4 yields two trees whose member nodes are {5} and {1,2,3,6,7}. The larger of these two trees has five nodes, thus the balance of node 4 is five. Deleting node 1 yields a forest of three trees of equal size: {2,6}, {3,7}, and {4,5}. Each of these trees has two nodes, so the balance of node 1 is two.

For each input tree, calculate the node that has the minimum balance. If multiple nodes have equal balance, output the one with the lowest number.

Input

The first line of input contains a single integer t (1 <= t <= 20), the number of test cases. The first line of each test case contains an integer N (1 <= N <= 20,000), the number of congruence. The next N-1 lines each contains two space-separated node numbers that are the endpoints of an edge in the tree. No edge will be listed twice, and all edges will be listed.

Output

For each test case, print a line containing two integers, the number of the node with minimum balance and the balance of that node.

Sample Input

1
7
2 6
1 2
1 4
4 5
3 7
3 1

Sample Output

1 2
 
题意:建立一棵树,要求删除一个节点后,得到的几棵树节点数平衡,而且节点数要尽可能多,输出删除的节点与节点数
思路:树形DP,记录每个点的节点数与该点子树的最大节点数,进行搜索
 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;

struct node
{
    int now,next;
} tree[40005];

int n,sum[40005],son[20005];
int head[20005],vis[20005],len;
//sum数组代表包含该节点与该点子节点数量和
//son数组代表该节点包含的所有子树的最大节点数
void add(int x,int y)//建树
{
    len++;
    tree[len].now = y;
    tree[len].next = head[x];
    head[x] = len;

    len++;
    tree[len].now = x;
    tree[len].next = head[y];
    head[y] = len;
}

void dfs(int root)
{
    int i,j;
    vis[root] = 1;
    for(i = head[root]; i!=-1; i = tree[i].next)
    {
        if(!vis[tree[i].now])
        {
            dfs(tree[i].now);
            sum[root]+=sum[tree[i].now];
            if(son[root]<sum[tree[i].now])
                son[root] = sum[tree[i].now];
        }
    }
}


int main()
{
    int T,i,j,x,y,ans,pos;
    scanf("%d",&T);
    while(T--)
    {
        len = 0;
        scanf("%d",&n);
        memset(tree,0,sizeof(tree));
        memset(head,-1,sizeof(head));
        for(i = 1; i<n; i++)
        {
            scanf("%d%d",&x,&y);
            add(x,y);
        }
        memset(son,0,sizeof(son));
        memset(vis,0,sizeof(vis));
        for(i = 0; i<=n; i++)
            sum[i] = 1;
        dfs(1);
        pos = 1;
        ans = son[1];
        for(i = 2; i<n; i++)
        {
            if(ans>max(sum[1]-sum[i],son[i]))
            {
                ans = max(sum[1]-sum[i],son[i]);
                pos = i;
            }
        }
        printf("%d %d\n",pos,ans);
    }

    return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值