1200. Stick

题目:

将不能够配对的筷子输出

Input

The input file will consist of several cases.
Each case will be presented by an integer n (1<=n<=100, and n is odd) at first. Following that, n positive integers will be given, one in a line. These numbers indicate the length of the sticks collected by Anthony.
The input is ended by n=0.

Output

For each case, output an integer in a line, which is the length of the last stick.

Sample Input

3
1
2
1
0

Sample Output

2

#include<iostream>
using namespace std;

int main() {
  int n;
  int sticks[100];
  while (cin >> n && n != 0) {
    for (int i = 0; i < n; ++i)
      cin >> sticks[i];
    for (int i = 0; i < n; ++i) {
      if (sticks[i] == -1) continue;
      for (int j = 0; j < n; ++j) {
        if (sticks[i] == sticks[j]&&i != j) {
          sticks[i] = -1;
          sticks[j] = -1;
          break;
        }
      }
    }
    for (int i = 0; i < n; ++i)
      if (sticks[i] != -1)
      cout << sticks[i] << endl;
  }
  return 0;
}
// #include<iostream>
// using namespace std;
//
// int main() {
//   int n;
//   while (cin >> n&&n != 0) {
//     int temp;
//     int result = 0;
//     while (n--) {
//       cin >> temp;
//       // 两个相同的数做异或运算得0,0与任何数做异或运算是其本身
//       result ^= temp;
//     }
//     cout << result << endl;
//   }
//   return 0;
// }
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值