PAT A1140 2019.08.22 【string】

1140 Look-and-say Sequence (20 分)

Look-and-say sequence is a sequence of integers as the following:

D, D1, D111, D113, D11231, D112213111, ...

where D is in [0, 9] except 1. The (n+1)st number is a kind of description of the nth number. For example, the 2nd number means that there is one D in the 1st number, and hence it is D1; the 2nd number consists of one D(corresponding to D1) and one 1 (corresponding to 11), therefore the 3rd number is D111; or since the 4th number is D113, it consists of one D, two 1's, and one 3, so the next number must be D11231. This definition works for D = 1 as well. Now you are supposed to calculate the Nth number in a look-and-say sequence of a given digit D.

Input Specification:

Each input file contains one test case, which gives D (in [0, 9]) and a positive integer N (≤ 40), separated by a space.

Output Specification:

Print in a line the Nth number in a look-and-say sequence of D.

Sample Input:

1 8

Sample Output:

1123123111

思路分析 

简单的字符串处理

最重要的是把题目读懂,把题目中给的样例读懂,

比如:字符X有Y个  那么输出就是XY

#include<cstdio>
#include<iostream>
#define MAX 100000
using namespace std;

int d,n;
int data[MAX];
int stack[MAX];
int top=-1;

int main()
{
    scanf("%d %d",&d,&n);
    
    if(n==1)
	{
		printf("%d",d);
		return 0;
	}
	int first=d;
	data[0]=d;
	int dataTop=0;
	
	for(int i=1;i<n;i++)//循环次数 
	{
//		cout<<"original:";
//		for(int j=0;j<=dataTop;j++)
//		  cout<<data[j];
//		  cout<<endl;
		int time=0;
		first=data[0];
		for(int j=0;j<=dataTop;j++)
		{

			if(data[j]!=first)
			{
				stack[++top]=first;
				stack[++top]=time;
				
				first=data[j];
				time=0;
			}
			time++;
		}
		stack[++top]=data[dataTop];
	    stack[++top]=time;
//	    cout<<time<<endl;
	    
	    if(i==n-1)
	    for(int j=0;j<=top;j++)
	      cout<<stack[j];
//	      cout<<endl;
	      
	    for(int j=0;j<=top;j++)
	      data[j]=stack[j];
	    dataTop=top;
	    top=-1;
//	    break;
	}
}

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值