PAT A1073/B1024 2019.07.07 【字符串处理】

1073 Scientific Notation (20 分)

Scientific notation is the way that scientists easily handle very large numbers or very small numbers. The notation matches the regular expression [+-][1-9].[0-9]+E[+-][0-9]+ which means that the integer portion has exactly one digit, there is at least one digit in the fractional portion, and the number and its exponent's signs are always provided even when they are positive.

Now given a real number A in scientific notation, you are supposed to print A in the conventional notation while keeping all the significant figures.

Input Specification:

Each input contains one test case. For each case, there is one line containing the real number A in scientific notation. The number is no more than 9999 bytes in length and the exponent's absolute value is no more than 9999.

Output Specification:

For each test case, print in one line the input number A in the conventional notation, with all the significant figures kept, including trailing zeros.

Sample Input 1:

+1.23400E-03

Sample Output 1:

0.00123400

Sample Input 2:

-1.2E+10

Sample Output 2:

-12000000000

思路分析

科学计数法转换为真实值

要会使用C语言输入输出字符串,懂得ASCII码与数字的转换关系,我在算指数的时候使用了一个顺序栈

做题之前需要把可能出现的输入情况考虑清楚,如指数为正时,需要补足0与不需要补足0的情况

 

#include<cstdio>
#include<cstring>
#include<iostream>
#include<cmath> 
#define MAX 10000
char str[MAX];

int main()
{
	scanf("%s",str);
	if(str[0]=='-')printf("-");
	
	//找到E的位置 
	int ePosition=0;
    //计算底数小数点后有几位 
	int downNum=0;
	for(int i=3;i<strlen(str);i++)
	{
		if(str[i]=='E')
        {
            ePosition=i;
            break;
        }
        downNum++;
	}
//	printf("E position:%d\n",ePosition);
//	printf("point to E has position count:%d\n",downNum);

	
	//算出指数的大小--因为指数不超过9999所以时间复杂度很小
	int arr[10]={0};//存放指数 --简易栈 
	int temp=0;
	for(int i=ePosition+2;i<strlen(str);i++)
	{
		arr[temp++]=str[i] - 48; 
	}
	int expo=0,temp2=0;
	while(temp--)//temp最多为4
	{
		expo=expo+arr[temp]*pow(10,temp2++);
	}
//	printf("expo:%d\n",expo);//指数验证 
	

	
	//输出部分1-指数为正 
	if(str[ePosition+1]=='+')
	if(expo==0)
	{
		for(int i=1;i<ePosition;i++)
		printf("%c",str[i]);
	}
	else if(expo<downNum)//要注意这种情况的判断(不用补0的情况)没考虑到会有一个点超时
	{
		int i=0;
		printf("%c",str[1]);
		for(i=3;i<=2+expo;i++)
		{
			printf("%c",str[i]);
		}
		printf(".");
		for(;i<ePosition;i++)
		printf("%c",str[i]);
		
	}
	else
	{
		int zeroNum = expo - downNum;
	    if(str[ePosition+1]=='+')
	    {
		printf("%c",str[1]);
		for(int i=3;i<ePosition;i++)
		{
			printf("%c",str[i]);
		}
		    while(zeroNum--)printf("0");
	    } 
	}

	
	//输出部分2-指数为负
	if(str[ePosition+1]=='-')
	if(expo==0)
	{
		for(int i=1;i<ePosition;i++)
		printf("%c",str[i]);
	}
	else
	{
		printf("0.");
		int temp=expo-1;//temp为小数点后补足几个0
		while(temp--)
		{
			printf("0");
		} 
		printf("%c",str[1]);//原先小数点前的一位
		for(int i=3;i<ePosition;i++)
		printf("%c",str[i]); 
		
	} 
	 
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值