PAT A1019 2019.07.14 【进制转换】

1019 General Palindromic Number (20 分)

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​<b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes
1 1 0 1 1

Sample Input 2:

121 5

Sample Output 2:

No
4 4 1

思路分析

进制转换问题,注意输入的数字和进制会很大,所以要使用lld,

并且栈的大小要尽可能大一些,否则会出现运行时错误。

进栈后判断是否对称 可以直接对栈遍历一半即可,

使用一个标志位来记录其特征是否符合题目中定义的数据类型

 

#include<cstdio>
#include<iostream>

int main()
{
	long long int n=0,b=0;
	scanf("%lld %lld",&n,&b);
	if(n<=0||b<2)return 0;
	int stack[100]={0};//注意栈的大小设置-n很大 b很小的情况
	int top=-1;
	int temp=n;
	
	while(1)
	{
		if(temp==0)break;
		stack[++top]=temp%b;
		temp=temp/b;
	}
	
	int flag=1;
	for(int i=0;i<=top/2;i++)
	{
		if(stack[i]!=stack[top-i])
		{
			flag = 0;
			break;
		}
	}
	
	
	if(n==0)printf("Yes\n0");
	else 
	{	
		if(flag==0)printf("No\n");
		else printf("Yes\n");
		for(int i=top;i>=0;i--)
		{
			if(i!=0)
			printf("%d ",stack[i]);
			else
			printf("%d",stack[i]);
			
		}
		
	}
	
} 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值