PAT A1085 2019.07.21 【sort】

1085 Perfect Sequence (25 分)

Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×pwhere M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter. In the second line there are N positive integers, each is no greater than 10​9​​.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

 

思路分析

主要要明白题意 最后输出的是最长完美序列的长度

转换一下也就是 在递增序列中选择 连续若干个数 使其符合完美序列的条件

最后输出其长度

如果使用 O(n^2)的排序会 -3分

如果使用O(n^2)的查找会-10分

所以要熟悉STL中的相关函数 如 sort upper_bound 等等

#include<cstdio>
#include<iostream>
#include<algorithm>
#define MAX 100010
using namespace std;

long long int arr[MAX]={0};

int main()
{
	//输入部分 
	int n=0;
	long long int p = 0;
	scanf("%d %lld",&n,&p);
	for(int i=0;i<n;i++)
	{
		scanf("%lld",&arr[i]);
	}
	
//	//复杂度为最大的排序方法 
//	for(int j=0;j<n;j++)
//	for(int i=1;i<n;i++)
//	{
//		if(arr[i-1]>arr[i])
//		{
//			long long int temp=0;
//			temp=arr[i-1];
//			arr[i-1]=arr[i];
//			arr[i]=temp;
//		}
//	}

    sort(arr,arr+n); 
	
	//数据处理
	int output=1;
	
	for(int i=0;i<n;i++)
	{
		//从 a [i+1,n) 找第一个 超过a[i]*p的数 
	    int position = upper_bound(arr+i+1,arr+n,(long long)arr[i] *p)-arr;
		output=max(output,position-i);
	}
	

	printf("%d",output);

}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值