PAT A1085

  • 题目:
    Given a sequence of positive integers and another positive integer p. The sequence is said to be a perfect sequence if M≤m×p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.
Input Specification:

Each input file contains one test case. For each case, the first line contains two positive integers N and p, where N (≤10​5​​) is the number of integers in the sequence, and p (≤10​9​​) is the parameter. In the second line there are N positive integers, each is no greater than 10​9​​.
Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.
Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

  • 题目大意
    从n个正整数中选择若干个数,使得选出的这些数中最大值不超过最小值的p倍。问满足条件的选择方案中,选出的数的最大个数

  • 方法一:双指针法
    分析:
    1.对输入的数组排序
    2.对每个1~n-1个数,i指向开头的数, j指向尾部的数,若j < n && A[j] <= (long long)A[i]*p,记录下j-i+1,
    3.输出j-i+1中最大值

代码实现:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
const int Max = 100010;
int main()
{
    int A[Max];
    int n, p;
    cin >> n >> p;
    for(int i = 0; i < n; i++)
        scanf("%d", &A[i]);
    sort(A, A+n);                 //对A数组从小到大排序
    int ans = 0;
    int i = 0, j = 0;
    while(i < n && j< n){
        while(j < n && A[j] <= (long long)A[i]*p)
        {
            j++;
            ans = max(ans, j-i+1);
        }
        i++;
    }
    cout << ans;
    return 0;


}

  • 方法二:二分法
    分析:对于每个A[i],只用找到第一个A[j],使得A[j] > A[i]*p;输出最大的j-i;

代码实现:

#include <iostream>
#include <algorithm>
#include <cstdio>
using namespace std;
int A[100010], n, p;
int binSearch(int i, long long x ){
    if(A[n-1] < x)
        return n;
    int l = i+1, r = n-1, mid;
    while(l < r){
        mid = (l+r)/2;
        if(A[mid] <= x)
            l = mid + 1;
        else
            r = mid;
    }
    return l;
}
int main()
{
    scanf("%d%d", &n, &p);
    for(int i = 0; i < n; i++){
        scanf("%d",&A[i]);
    }
    sort(A, A+n);                     //对数组A从小到大排序
    int ans = 0;
    for(int i =0; i < n; i++){
        int j = binSearch(i, (long long)A[i] * p);
        ans = max(ans, j-i);
    }
    printf("%d", ans);
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值