PAT A1154 2019.08.14 【自定义图判断 map】

1154 Vertex Coloring (25 分)

proper vertex coloring is a labeling of the graph's vertices with colors such that no two vertices sharing the same edge have the same color. A coloring using at most k colors is called a (proper) k-coloring.

Now you are supposed to tell if a given coloring is a proper k-coloring.

Input Specification:

Each input file contains one test case. For each case, the first line gives two positive integers N and M (both no more than 10​^4​​), being the total numbers of vertices and edges, respectively. Then M lines follow, each describes an edge by giving the indices (from 0 to N−1) of the two ends of the edge.

After the graph, a positive integer K (≤ 100) is given, which is the number of colorings you are supposed to check. Then K lines follow, each contains N colors which are represented by non-negative integers in the range of int. The i-th color is the color of the i-th vertex.

Output Specification:

For each coloring, print in a line k-coloring if it is a proper k-coloring for some positive k, or No if not.

Sample Input:

10 11
8 7
6 8
4 5
8 4
8 1
1 2
1 4
9 8
9 1
1 0
2 4
4
0 1 0 1 4 1 0 1 3 0
0 1 0 1 4 1 0 1 0 0
8 1 0 1 4 1 0 5 3 0
1 2 3 4 5 6 7 8 8 9

Sample Output:

4-coloring
No
6-coloring
No

思路分析:

给定一个图,再给定每个结点的颜色。在此图中,如果任意两相邻结点都有不同颜色,

输出X-coloring,X为图中颜色种类数量,否则输出No

因为输入量为10^4数量级,所以建图采用 第一维度固定、第二维度变长的vector来实现邻接链表

用一个color数组来记录每个结点的颜色,用一个map辅助计算颜色种类(这里最好使用STL以免出现错误)

之后判断输出情况,只需对此图的邻接链表进行遍历即可(每个表头的颜色与其邻接结点的颜色进行对比)

#include<cstdio>
#include<iostream>
#include<vector>
#include<map> 
#define MAX 10010
using namespace std;

vector<int> v[MAX];
int n,m;
int k;
int color[MAX];
map<int,int>colorMap;

int main()
{
	
	scanf("%d %d",&n,&m);//m-edge n-vertex
	for(int i=0;i<m;i++)
	{
		int a,b;
		scanf("%d %d",&a,&b);
		v[a].push_back(b);
		v[b].push_back(a);
	}
	
	scanf("%d",&k);
	while(k--)
	{
		int colorNum=0;
		int flag=1;
        colorMap.clear();//此处map操作注意!
		for(int i=0;i<MAX;i++)
			color[i]=-1;
		
		for(int i=0;i<n;i++)
		{
			int temp;
			scanf("%d",&temp);
			if(colorMap[temp]==0)
			{
				colorMap[temp]=1;
				colorNum++;
			}
			color[i]=temp;
		}
		
		for(int i=0;i<n;i++)
		{
			if(flag==0)break;
			for(int j=0;j<v[i].size();j++)
			{
				if(color[i]==color[v[i][j]])
				{
					printf("No\n");
					flag=0;
					break;
				}
			}
		}
		
		if(flag==1)
            printf("%d-coloring\n",colorNum);
	}
	
	

} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值