PAT A1130 2019.08.20 【DFS 中缀表达式】

1130 Infix Expression (25 分)

Given a syntax tree (binary), you are supposed to output the corresponding infix expression, with parentheses reflecting the precedences of the operators.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20) which is the total number of nodes in the syntax tree. Then N lines follow, each gives the information of a node (the i-th line corresponds to the i-th node) in the format:

data left_child right_child

where data is a string of no more than 10 characters, left_child and right_child are the indices of this node's left and right children, respectively. The nodes are indexed from 1 to N. The NULL link is represented by −1. The figures 1 and 2 correspond to the samples 1 and 2, respectively.

infix1.JPGinfix2.JPG
Figure 1Figure 2

Output Specification:

For each case, print in a line the infix expression, with parentheses reflecting the precedences of the operators. Note that there must be no extra parentheses for the final expression, as is shown by the samples. There must be no space between any symbols.

Sample Input 1:

8
* 8 7
a -1 -1
* 4 1
+ 2 5
b -1 -1
d -1 -1
- -1 6
c -1 -1

Sample Output 1:

(a+b)*(c*(-d))

Sample Input 2:

8
2.35 -1 -1
* 6 1
- -1 4
% 7 8
+ 2 3
a -1 -1
str -1 -1
871 -1 -1

Sample Output 2:

(a*2.35)+(-(str%871))

思路分析

对于此类输入利用三次遍历依次进行初始化、建树&&初始化孩子标志位 与 找出root 的任务

之后对根进行 dfs递归,最后返回的结果经过处理(去掉最外层的括号)即为所需的输出结果

此处把递归函数单独摘出

分情况讨论如下:

左存右存:  (dfs左 输出根 dfs右)

左不存右不存:  输出根

左不存右存: (根 dfs右)

左存右不存(不存在)

	//liuchuo's algorithm
	string out=dfs(root);
	  //the root is +-*/% , so extra two char '(' and ')' are needless
	if(out[0]=='(')out=out.substr(1,out.size()-2);
	cout<<out;


//liuchuo's algorithm
string dfs(NODE *root) 
{
	if(root->left==NULL&&root->right==NULL)return root->data;
	if(root->left==NULL&&root->right!=NULL)
	  return "("+root->data+dfs(root->right)+")";
	if(root->left!=NULL&&root->right!=NULL)
	  return "("+dfs(root->left)+root->data+dfs(root->right)+")";
}

 

#include<cstdio>
#include<iostream>
#include<string>
#define MAX 30
using namespace std;

typedef struct NODE{
	string data;
	struct NODE *left;
	struct NODE *right;
	int isChild;
}NODE;

NODE *node[MAX];
int n;

//liuchuo's algorithm
string dfs(NODE *root) 
{
	if(root->left==NULL&&root->right==NULL)return root->data;
	if(root->left==NULL&&root->right!=NULL)
	  return "("+root->data+dfs(root->right)+")";
	if(root->left!=NULL&&root->right!=NULL)
	  return "("+dfs(root->left)+root->data+dfs(root->right)+")";
}


int main()
{
	cin>>n;
	
	//first traverse--init and apply for location
	for(int i=1;i<=n;i++)
	{
		node[i] = new NODE;
		node[i]->left=NULL;
		node[i]->right=NULL;
		node[i]->isChild=0;
	}
	
	//second traverse--build tree and set isChild-bit
	for(int i=1;i<=n;i++)
	{
		int left,right;
		cin>>node[i]->data;
		scanf("%d %d",&left,&right);
		if(left!=-1)
		{
			node[i]->left=node[left];
			node[left]->isChild=1;
		}
		if(right!=-1)
		{
			node[i]->right=node[right];
			node[right]->isChild=1;
		}
	}
	
	//third traverse--find root
	NODE *root = new NODE;
	for(int i=1;i<=n;i++)
	{
		if(node[i]->isChild==0)root=node[i];
	}
	
	
	//liuchuo's algorithm
	string out=dfs(root);
	  //the root is +-*/% , so extra two char '(' and ')' are needless
	if(out[0]=='(')out=out.substr(1,out.size()-2);
	cout<<out;
	
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值