题目
【问题描述】3、完全二叉树的顺序存储结构通常用一组地址连续的存储单元依
次自上而下、自左至右存储完全二叉树上的结点元素,对于一般二叉树,则应将
其每个结点与完全二叉树上的结点相对照,存储在一维数组的相应分量中。如下
图(a)所示的一般二叉树的存储结构如图(b)所示,图(b)中以0表示空结点。试编
写算法输出二叉树中任一非空结点值的双亲结点的值,如果没有双亲则输出0。
【输入形式】
按照完全二叉树输入的结点个数
二叉树结点值输入,每个数之间用一个空格隔开,用
0
表示空结点,树中所有非空结点值不
相同。
任一非空结点值
【输出形式】任一非空结点值的双亲结点值
【样例输入】
7
35 20 19 0 13 0 47
13
【样例输出】
20
#include <stdio.h>
#include <stdlib.h>
#define MAX_TREE_SIZE 100
#define TElemType int
typedef TElemType SqBiTree[MAX_TREE_SIZE];
SqBiTree bt;
void buildBinaryTree(int n) {
int i;
for (i = 0; i < n; i++) {
scanf("%d", &bt[i]);
}
}
int findParent(int n, int target) {
int i;
for (i = 1; i < n; i++) {
if (bt[i] == target) {
return bt[(i - 1) / 2];
}
}
return -1; // Parent not found
}
int main() {
int n, i, target;
printf("Enter the number of nodes: ");
scanf("%d", &n);
printf("Enter the values of the nodes: ");
buildBinaryTree(n);
printf("Enter the value of the node to find its parent: ");
scanf("%d", &target);
int parent = findParent(n, target);
if (parent != -1) {
printf("Parent of %d is: %d\n", target, parent);
} else {
printf("Parent not found for the given value.\n");
}
return 0;
}