题目:http://poj.org/problem?id=1979
Description
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Write a program to count the number of black tiles which he can reach by repeating the moves described above.
Input
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.
'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.
Output
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
Sample Input
6 9 ....#. .....# ...... ...... ...... ...... ...... #@...# .#..#. 11 9 .#......... .#.#######. .#.#.....#. .#.#.###.#. .#.#..@#.#. .#.#####.#. .#.......#. .#########. ........... 11 6 ..#..#..#.. ..#..#..#.. ..#..#..### ..#..#..#@. ..#..#..#.. ..#..#..#.. 7 7 ..#.#.. ..#.#.. ###.### ...@... ###.### ..#.#.. ..#.#.. 0 0
Sample Output
45 59 6 13分析:
BFS。
代码:
#include <iostream>
#include <queue>
#include <cstring>
int dx[] = {-1, 1, 0, 0};
int dy[] = {0, 0, -1, 1};
int main()
{
char map[22][22];
bool visited[22][22];
int W, H;
std::pair<int, int> start;
while (true)
{
std::cin >> W >> H;
if(W == 0 && H == 0)
break;
memset(map, '#', sizeof(map));
memset(visited, false, sizeof(visited));
for(int i = 0; i < H; ++i)
{
for(int j = 0; j < W; ++j)
{
std::cin >> map[i][j];
if(map[i][j] == '@')
{
start = std::make_pair(i, j);
}
}
}
std::queue<std::pair<int, int> > q;
q.push(start);
visited[start.first][start.second] = true;
int count = 1;
while (!q.empty())
{
int x = q.front().first;
int y = q.front().second;
q.pop();
for(int i = 0; i < 4; ++i)
{
int newx = x + dx[i];
int newy = y + dy[i];
if(newx >= 0 && newx < H && newy >= 0 && newy < W)
{
if(!visited[newx][newy] && map[newx][newy] == '.')
{
q.push(std::make_pair(newx, newy));
visited[newx][newy] = true;
++count;
}
}
}
}
std::cout << count << std::endl;
}
return 0;
}
感谢阅读!