Doing Homework again HDU - 1789 贪心

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input
The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow.
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores.
Output
For each test case, you should output the smallest total reduced score, one line per test case.
Sample Input
3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4
Sample Output
0
3
5


题意:有t组数据,吗,每组有n们科目,每门科目完成的天数是一天,接下来两行是最迟的天限,减少的分数。在规定天限之内完成不减少分数。 求最少减除的分数。
  思路:正着走,考虑的情况太多,可以反着来,从最后一天开始,把最后时限大于当前天的分数放入优先队列当中,删除最大的减少分数,最后留在队列中的就是最小的天数。


#include<cstdio>
#include<queue>
#include<cstring>
#include<algorithm>
using namespace std;
const int M=2000;
typedef long long ll;
int t,n;
struct point
{
    int dead,cost;
}e[M];
int vis[1000];
bool cmp(point a,point b)
{
        return a.dead>b.dead;
}
int main()
{
    long long ans;
    int i,j;
    scanf("%d",&t);
    while(t--)
    {
        ans=0;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d",&e[i].dead);
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&e[i].cost);
            ans+=e[i].cost;
        }
        sort(e+1,e+n+1,cmp);
        priority_queue<int>que;
        j=1;
        for(i=n;i>0;i--)
        {
            for(;j<=n;j++)
            {
                if(e[j].dead<i)
                {
                    break;
                }
                que.push(e[j].cost);
            }
            if(que.size())
            {
                ans-=que.top();
                que.pop();
            }
        }
        printf("%lld\n",ans);
    }
    return 0;
}



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值