GCD HDU - 1695 莫比乌斯模板

Given 5 integers: a, b, c, d, k, you're to find x in a...b, y in c...d that GCD(x, y) = k. GCD(x, y) means the greatest common divisor of x and y. Since the number of choices may be very large, you're only required to output the total number of different number pairs.
Please notice that, (x=5, y=7) and (x=7, y=5) are considered to be the same.

Yoiu can assume that a = c = 1 in all test cases.

Input

The input consists of several test cases. The first line of the input is the number of the cases. There are no more than 3,000 cases.
Each case contains five integers: a, b, c, d, k, 0 < a <= b <= 100,000, 0 < c <= d <= 100,000, 0 <= k <= 100,000, as described above.

Output

For each test case, print the number of choices. Use the format in the example.

Sample Input

2
1 3 1 5 1
1 11014 1 14409 9

Sample Output

Case 1: 9
Case 2: 736427


        
  

Hint

For the first sample input, all the 9 pairs of numbers are (1, 1), (1, 2), (1, 3), (1, 4), (1, 5), (2, 3), (2, 5), (3, 4), (3, 5).
        
 莫比乌斯模板



#include<map>
#include<set>
#include<queue>
#include<stack>
#include<cmath>
#include<deque>
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

typedef long long ll;
const int inf = 0x3f3f3f3f;
const int M = 1e6 + 10;
int t;
int mo[M],prime[M];
int a,b,c,d,k;
bool check[M];
void Mobius()
{
    memset(check,0,sizeof(check));
    int kk=0;
    mo[1]=1;
    for(int i=2;i<M;i++)
    {
        if(!check[i])
        {
            prime[kk++]=i;
            mo[i]=-1;
        }
        for(int j=0;j<kk;j++)
        {
            if(prime[j]*i>=M)
                break;
            check[i*prime[j]]=true;
            if(i%prime[j]==0)
            {
                mo[i*prime[j]]=0;
                break;
            }
            mo[i*prime[j]]=-mo[i];
        }
    }
}
int main()
{
    scanf("%d",&t);
    Mobius();
    int kk=1;
    while(t--)
    {
        scanf("%d%d%d%d%d",&a,&b,&c,&d,&k);
        if(k==0){
            printf("Case %d: 0\n",kk++);
            continue;
        }
        b=b/k;
        d=d/k;
        int num=min(d,b);
        ll ans1=0,ans2=0;
        for(int i=1;i<=b;i++)
            ans1+=(ll)mo[i]*(b/i);
        for(int i=1;i<=b;i++)
            ans2+=(ll)mo[i];
        printf("Case %d: %lld\n",kk++,ans1-ans2/2);
    }
    return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值