本题要求将任一给定元素插入从大到小排好序的数组中合适的位置,以保持结果依然有序。
函数接口定义:
bool Insert( List L, ElementType X );
其中List结构定义如下:
typedef int Position;
typedef struct LNode *List;
struct LNode {
ElementType Data[MAXSIZE];
Position Last; /* 保存线性表中最后一个元素的位置 */
};
L是用户传入的一个线性表,其中ElementType元素可以通过>、==、<进行比较,并且题目保证传入的数据是递减有序的。函数Insert要将X插入Data[]中合适的位置,以保持结果依然有序(注意:元素从下标0开始存储)。但如果X已经在Data[]中了,就不要插入,返回失败的标记false;如果插入成功,则返回true。另外,因为Data[]中最多只能存MAXSIZE个元素,所以如果插入新元素之前已经满了,也不要插入,而是返回失败的标记false。
裁判测试程序样例:
#include <stdio.h>
#include <stdlib.h>
#define MAXSIZE 10
typedef enum {false, true} bool;
typedef int ElementType;
typedef int Position;
typedef struct LNode *List;
struct LNode {
ElementType Data[MAXSIZE];
Position Last; /* 保存线性表中最后一个元素的位置 */
};
List ReadInput(); /* 裁判实现,细节不表。元素从下标0开始存储 */
void PrintList( List L ); /* 裁判实现,细节不表 */
bool Insert( List L, ElementType X );
int main()
{
List L;
ElementType X;
L = ReadInput();
scanf("%d", &X);
if ( Insert( L, X ) == false )
printf("Insertion failed.\n");
PrintList( L );
return 0;
}
/* 你的代码将被嵌在这里 */
输入样例1:
5
35 12 8 7 3
10
输出样例1:
35 12 10 8 7 3
Last = 5
输入样例2:
6
35 12 10 8 7 3
8
输出样例2:
Insertion failed.
35 12 10 8 7 3
Last = 5
参考代码
bool Insert( List L, ElementType X )
{
if(L->Last==MAXSIZE-1)
{
return false;
}
int i;
for(i=0;i<=L->Last;i++)
{
if(X==L->Data[i])
{
return false;
}
else if(X>L->Data[i])
{
int j;
for(j=L->Last;j>=i;j--)
{
L->Data[j+1]=L->Data[j];
}
L->Data[i]=X;
L->Last++;
break;
}
else if(i==L->Last)
{
L->Data[L->Last+1]=X;
L->Last++;
break;
}
}
return true;
}
另外两个函数参考代码
List ReadInput()
{
List L;
L=(List)malloc(sizeof(struct LNode));
int x;
scanf("%d",&x);
L->Last=x-1;
int i;
for(i=0;i<=L->Last;i++)
{
scanf("%d",&L->Data[i]);
}
return L;
}
void PrintList( List L )
{
int i;
for(i=0;i<=L->Last;i++)
{
printf("%d",L->Data[i]);
if(i==L->Last)
{
printf("\n");
}
else
{
printf(" ");
}
}
printf("Last = %d",L->Last);
}
思路:
首先判断线性表数组中元素是否已满;接着遍历线性表数组中每个元素,如果要插入元素已存在,则返回false,否则将要插入元素与数组中元素比较,因为数组中元素是递减的,只需要找到在数组中比要插入的元素小的值,则将插入元素放入该位置,该位置后元素(包括该位置)统一后移一位;如果遍历到最后一个元素时,还未找到比要插入的元素还小的值,则要插入的元素即为最小元素,则将该元素插入到数组最后一位元素后。