解决使用pip安装lxml包报错问题

版权声明:本文为博主原创文章,未经博主允许不得转载,未经允许将会考虑法律手段维权。 https://blog.csdn.net/lincifer/article/details/51296559

解决使用pip安装lxml包报错问题

tags : Python


基于Ubuntu15.10,其他发行版未测试过是否有效。如果懒得看前面的排查过程的话可以直接使用最后那个命令。

今天想要试试beautifulsoup4,安装的时候很顺利,然后就准备安装lxml作为解析器,没想到安装时pip直接给我报了一整页的错误。

解决过程

查看了一下错误提示,其中有如下一段:

*********************************************************************************
Could not find function xmlCheckVersion in library libxml2. Is libxml2 installed?
*********************************************************************************

于是我手动安装这个库,结果发现实际上已经安装过了,那么为什么还会提示这个问题呢?于是我又回去看输出的提示,找到了这两行:

ERROR: b'/bin/sh: 1: xslt-config: not found\n'
** make sure the development packages of libxml2 and libxslt are installed **

原来要安装dev包啊。输入sudo apt-get install libxml2-dev libxslt1-dev,应该搞定了吧?

事实证明我高兴太得早了,虽然不再报这个错了,但是lxml的安装还是失败了。无奈,只能继续看错误提示。找到了这么一个错误提示:

src/lxml/lxml.etree.c:82:20: fatal error: Python.h: 没有那个文件或目录

查了一下,这是python-dev中提供的一个头文件,所以需要安装python-dev(我用的是Python3,所以装了python3-dev)。用apt安装一下,然后再用pip install lxml,没想到依旧报错不能安装orz。这次错误换了一个:

/usr/bin/ld: cannot find -lz

stackoverflow上对于这个问题提供的方法是安装zlib1g-dev,用apt-get安装后,再次尝试编装lxml,终于编译安装成功。

总结

实际上用一条命令吧所需的几个dev包装上就能搞定了。

sudo apt-get install python-dev python3-dev libxml2-dev libxslt1-dev zlib1g-dev

后来发现Stackoverflow上的已经有人问了这个问题。传送门

展开阅读全文

没有更多推荐了,返回首页