POJ - 3021 e-Coins (bfs)


e-Coins
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 750 Accepted: 372

Description

At the Department for Bills and Coins, an extension of today's monetary system has newly been proposed, in order to make it fit the new economy better. A number of new so called e-coins will be produced, which, in addition to having a value in the normal sense of today, also have an InfoTechnological value. The goal of this reform is, of course, to make justice to the economy of numerous dotcom companies which, despite the fact that they are low on money surely have a lot of IT inside. All money of the old kind will keep its conventional value and get zero InfoTechnological value. 

To successfully make value comparisions in the new system, something called the e-modulus is introduced. This is calculated as SQRT(X*X+Y*Y), where X and Y hold the sums of the conventional and InfoTechnological values respectively. For instance, money with a conventional value of $3 altogether and an InfoTechnological value of $4 will get an e-modulus of $5. Bear in mind that you have to calculate the sums of the conventional and InfoTechnological values separately before you calculate the e-modulus of the money. 

To simplify the move to e-currency, you are assigned to write a program that, given the e-modulus that shall be reached and a list of the different types of e-coins that are available, calculates the smallest amount of e-coins that are needed to exactly match the e-modulus. There is no limit on how many e-coins of each type that may be used to match the given e-modulus.

Input

A line with the number of problems n (0 < n<=100), followed by n times:
  • A line with the integers m (0 < m<=40) and S (0 < S<=300), where m indicates the number of different e-coin types that exist in the problem, and S states the value of the e-modulus that shall be matched exactly.
  • m lines, each consisting of one pair of non-negative integers describing the value of an e-coin. The first number in the pair states the conventional value, and the second number holds the InfoTechnological value of the coin.
When more than one number are present on a line, they will be separated by a space. Between each problem, there will be one blank line.

Output

The output consists of n lines. Each line contains either a single integer holding the number of coins necessary to reach the specified e-modulus S or, if S cannot be reached, the string "not possible".

Sample Input

3 
2 5 
0 2 
2 0 

3 20 
0 2 
2 0 
2 1 

3 5 
3 0 
0 4 
5 5 

Sample Output

not possible 
10 
2

Hint

 
The illustration examplifies adding 8 coins of conventional value 2 and InfoTechnological value 1, and 2 coins with pure InfoTechnological value 2. The e-modulus is of course 20 as SQRT((8*2+2*0)^2+(8*1+2*2)^2)=SQRT(16^2+12^2)=20 

Source

[Submit]   [Go Back]   [Status]   [Discuss]

题意:     给出N种a和b值,让你从中选出最少的数量(每种取次数无限制),使得能够满足a^2+b^2=s^2

思路:用bfs搜索,把N种值放到一个结构体中,便于使用。

   

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<queue>
using namespace std;

int map[400][400];
int u[200],v[200],n,m;
int book[400][400];

struct node
{
    int x;
    int y;
    int step;
} ;

void bfs()
{
     memset(book,0,sizeof(book));
     queue<node> q;
     node now,tmp;
     now.x=0;
     now.y=0;
     now.step=0;
     book[0][0]=1;
     q.push(now);
     while(!q.empty())
     {
         now=q.front();
         q.pop();
         if(sqrt(now.x*now.x+now.y*now.y)==n)
         {
             printf("%d\n",now.step);
             return ;
         }
         for(int i=0;i<m;i++)
         {
             int tx=now.x+u[i];   
             int ty=now.y+v[i];
             if(tx*tx+ty*ty<=n*n&&book[tx][ty]==0)
             {
                 book[tx][ty]=1;
                 tmp.x=tx;
                 tmp.y=ty;
                 tmp.step=now.step+1;
                 q.push(tmp);
             }
         }
     }
     printf("not possible\n");
}
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&m,&n);
        for(int i=0;i<m;i++)
            scanf("%d%d",&u[i],&v[i]);
       bfs();
    }
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值