uva 10375 Choose and divide

 

Choose and divide

 
The binomial coefficient C(m, n) is defined as

C(m, n) = m!(m − n)! n!

Given four natural numbers p, q, r, and s, compute the the result of dividing C(p, q) by C(r, s).

Input

Input consists of a sequence of lines. Each line contains four non-negative integer numbers giving valuesfor p, q, r, and s, respectively, separated by a single space. All the numbers will be smaller than 10,000with p ≥ q and r ≥ s.

Output

For each line of input, print a single line containing a real number with 5 digits of precision in the fraction,giving the number as described above. You may assume the result is not greater than 100,000,000.

Sample Input

10 5 14 9
93 45 84 59
145 95 143 92
995 487 996 488
2000 1000 1999 999
9998 4999 9996 4998

Sample Output

0.12587
505606.46055
1.28223
0.48996
2.00000
3.99960

题意:求C(p,q)/C(r,s)的值

  由公式C(m, n) = m!/(m − n)! n!得 C(p,q) / C(r,s)== ( p! / q! (p - q)! )  *  ( s! (r - s)! / (r!) )

 而p!/(p-q)!=p*(p-1)*...(p-q+1)         (r-s)!/r!=r*(r-1)*...(r-s+1)

 故原式就等于 [ p*(p-1)*...(p-q+1) / q! ]* [ s! /r*(r-1)*...(r-s+1) ]

 注意:(p-q)应与p 进行比较找到较小的,用较小的进行运算 即C(p,q)=C(p,p-q)

           (r-s) 应与r 进行比较找到较小的,用较小的进行运算  即C(r,s)=C(r,r-s)

             要一边乘一边除否则爆

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
//C(p,q) / C(r,s)== (p!s!(r - s)!)/(q!(p - q)!r!)==p*(p-1)*...(p-q+1)/q! * s!/r*(r-1)*...(r-s+1)
//要一边乘一边除
int main()
{
    int p,q,r,s;
     while(~scanf("%d%d%d%d",&p,&q,&r,&s))
     {
         if(q>p-q)
            q=p-q;
         if(s>r-s)
            s=r-s;
         double sum=1.0;
         for(int i=1;i<=q||i<=s;i++)
         {
             if(i<=q)
                sum=sum*(p-i+1)/i;
             if(i<=s)
                sum=sum*i/(r-i+1);
         }
         printf("%.5lf\n",sum);
     }
}






  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值