HDU 3466 Proud Merchants (01背包排序问题)

详细解释,受益匪浅

http://www.mamicode.com/info-detail-1009053.html


http://www.cnblogs.com/chuanlong/archive/2013/01/13/2858915.html

                    Proud Merchants

  HDU - 3466 

Recently, iSea went to an ancient country. For such a long time, it was the most wealthy and powerful kingdom in the world. As a result, the people in this country are still very proud even if their nation hasn’t been so wealthy any more. 
The merchants were the most typical, each of them only sold exactly one item, the price was Pi, but they would refuse to make a trade with you if your money were less than Qi, and iSea evaluated every item a value Vi. 
If he had M units of money, what’s the maximum value iSea could get? 

Input
There are several test cases in the input. 

Each test case begin with two integers N, M (1 ≤ N ≤ 500, 1 ≤ M ≤ 5000), indicating the items’ number and the initial money. 
Then N lines follow, each line contains three numbers Pi, Qi and Vi (1 ≤ Pi ≤ Qi ≤ 100, 1 ≤ Vi ≤ 1000), their meaning is in the description. 

The input terminates by end of file marker. 

Output
For each test case, output one integer, indicating maximum value iSea could get. 

Sample Input
2 10
10 15 10
5 10 5
3 10
5 10 5
3 5 6
2 7 3
Sample Output
5
11

有关排序的01背包问题

该题要确保q-p小的先被”挑选“,差值越小使用它的价值越大(做出的牺牲越小).

把 5 10 5 看作p1,q1,v1,把 3 5  6 看作p2,q2,v2,即p1+q2<p2+q1,即q1-p1>q2-p2 。 先买差值大的物品再买差值小的物品,但是01背包的购买都是按照从后向前的顺序进行购买的,所以按照背包执行程序的时候是按照从小到大(x先排差值小的再排差值大的)的顺序!

//该题要确保q-p小的先被”挑选“,差值越小使用它的价值越大(做出的牺牲越小).
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;

int dp[5005];//定义DP数组,i表示还有i元钱,dp[i]表示i元钱所能购买物品的最大价值

struct node
{
    int p,q,v;
} a[550];

// 把 5 10 5 看作p1,q1,v1
// 把 3 5  6 看作p2,q2,v2
//即p1+q2<p2+q1
//即q1-p1>q2-p2   先买差值大的物品再买差值小的物品
int cmp(node a,node b)
{
    return (a.q-a.p)<(b.q-b.p);//注意这里的比较大小,01背包的购买都是按照从后向前的顺序进行购买的,所以按照背包执行程序的时候是按照从小到大的顺序!
}
int main()
{
    int n,m,i,j;
    while(~scanf("%d%d",&n,&m))
    {
        memset(dp,0,sizeof(dp));
        for(i=1; i<=n; i++)
            scanf("%d%d%d",&a[i].p,&a[i].q,&a[i].v);
        sort(a+1,a+n+1,cmp);
        for(i=1; i<=n; i++)
            for(j=m; j>=a[i].q; j--)
                dp[j]=max(dp[j],dp[j-a[i].p]+a[i].v);   //01背包
        printf("%d\n",dp[m]);
    }
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值