UVA11059 Maximum Product(暴力)

Given a sequence of integers S = {S1,S2,…,Sn}, you should determine what is the value of the maximum positive product involving consecutive terms of S. If you cannot find a positive sequence, you should consider 0 as the value of the maximum product.
Input Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si is an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each element in the sequence. There is a blank line after each test case. The input is terminated by end of file (EOF).
Output
For each test case you must print the message: ‘Case #M: The maximum product is P.’, where M is the number of the test case, starting from 1, and P is the value of the maximum product. After each test case you must print a blank line.
Sample Input
3 2 4 -3
5 2 5 -1 2 -1
Sample Output
Case #1: The maximum product is 8.
Case #2: The maximum product is 20.
题意分析:给出一个序列,问这个序列中最大连续累乘的子序列中,最大的值为多少,如果都为负数,则输出0.
解题思路:整个元素最多有18个,大小最大10.所以要开到long long,防止溢出(因为溢出我也错了无数遍。。。以后一定要记住。。。)。然后列举所有长度即可。另外要注意输出格式,每个样例都要输出一个空白行(之前曾因为这个空行一口气wa了5遍)

#include<cstdio>
#include<algorithm>
#include<iostream>
#include<cmath>
#include<iomanip>
#include<cstring>
#include<vector>
#include<iterator>
using namespace std;
int main()
{
    int n,i,c=0,j,k,s[18],t=0;
    while(scanf("%d", &n)!=EOF)
    {
        long long sum=0,ans;
        for(i=0; i<n; i++){
                scanf("%d", &s[i]);
        }
        for(i=0; i<n; i++){         //子序列长度
            for(j=0; j+i<n; j++){   //子序列起点
                ans=1;
                for(k=j; k<=j+i; k++){  //乘啊乘啊乘~~
                    ans *= s[k];
                }
                if(sum<ans) sum=ans;
            }
        }
        printf("Case #%d: The maximum product is %lld.\n\n", ++c, sum);
    }
    return 0;
}

我要是再错lld这个地方。。。我就可以去死一会了。。。 就因为这个wa了3次。。。以后注意注意。。。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值