B - Maximum Product

添加链接描述

Given a sequence of integers S = {S1, S2, . . . , Sn}, you should determine what is the value of the
maximum positive product involving consecutive terms of S. If you cannot find a positive sequence,
you should consider 0 as the value of the maximum product.
Input
Each test case starts with 1 ≤ N ≤ 18, the number of elements in a sequence. Each element Si
is
an integer such that −10 ≤ Si ≤ 10. Next line will have N integers, representing the value of each
element in the sequence. There is a blank line after each test case. The input is terminated by end of
file (EOF).
Output
For each test case you must print the message: ‘Case #M: The maximum product is P.’, where
M is the number of the test case, starting from 1, and P is the value of the maximum product. After
each test case you must print a blank line.
Sample Input
3
2 4 -3
5
2 5 -1 2 -1
Sample Output
Case #1: The maximum product is 8.
Case #2: The maximum product is 20.

题意:给一个序列a[n],找这个序列里连续的最大的乘积
思路:暴力枚举,找每个以a[i]为起点的最大连续序列,维护最大值

#include<stdio.h>
#include<string.h>
long long  ma(long long x,long long y)
{
    if(x>y)
        return x;
    else
        return y;
}
int main()
{
    int n,i,len=0,j;
    long long ans,max;
    int a[20];
    while(~scanf("%d",&n))
    {
        len++;
        ans=0;
        for(i=1; i<=n; i++)
        {
            scanf("%d",&a[i]);
        }
        for(i=1;i<=n;i++)
        {
            max=a[i];
            ans=ma(max,ans);//不要忘掉这一种情况(最大值只取a[i]一个数)
            for(j=i+1;j<=n;j++)
            {
                max*=a[j];
                ans=ma(max,ans);
            }
        }
        printf("Case #%d: The maximum product is %lld.\n",len,ans);
        printf("\n");
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值