Given a positive integer n, write a program to find out a nonzero multiple m of n whose decimal representation contains only the digits 0 and 1. You may assume that n is not greater than 200 and there is a corresponding m containing no more than 100 decimal digits.
Input
The input file may contain multiple test cases. Each line contains a value of n (1 <= n <= 200). A line containing a zero terminates the input.
Output
For each value of n in the input print a line containing the corresponding value of m. The decimal representation of m must not contain more than 100 digits. If there are multiple solutions for a given value of n, any one of them is acceptable.
Sample Input
2
6
19
0
Sample Output
10
100100100100100100
111111111111111111
题意:
有一个整数n,让你找一个适当的m(m只包含0和1且位数不超过100位)的整数
题解:
喵喵喵~这题真是有够坑的,,,我还以为要用到Java大数,,,100位,,,这道题总共有两条搜索路径,x*10或x*10+1。注意long long的范围,-(10^19)~(10^20),所以深搜次数不能超过19次,不然会崩掉。这是很重要的一点,也是解题的关键点!以后我一定要记住深搜次数这个问题。。。
#include<cstdio>
#include<iostream>
using namespace std;
typedef long long ll;
bool vis;
void dfs(ll m, int n, int step){
if(vis)
return ;
if(step == 19)
return ;
if(m % n == 0){
printf("%lld\n", m);
vis = 1;
return ;
}
dfs(m*10, n, step+1);
dfs(m*10+1, n, step+1);
}
int main(){
int n;
while(scanf("%d", &n), n){
vis = 0;
dfs(1, n, 0);
}
return 0;
}