poj 3984 迷宫问题(bfs+路径记录)

定义一个二维数组:


int maze[5][5] = {

    0, 1, 0, 0, 0,

    0, 1, 0, 1, 0,

    0, 0, 0, 0, 0,

    0, 1, 1, 1, 0,

    0, 0, 0, 1, 0,

};


它表示一个迷宫,其中的1表示墙壁,0表示可以走的路,只能横着走或竖着走,不能斜着走,要求编程序找出从左上角到右下角的最短路线。 

Input
一个5 × 5的二维数组,表示一个迷宫。数据保证有唯一解。
Output
左上角到右下角的最短路径,格式如样例所示。
Sample Input

0 1 0 0 0
0 1 0 1 0
0 0 0 0 0
0 1 1 1 0
0 0 0 1 0

Sample Output

(0, 0)
(1, 0)
(2, 0)
(2, 1)
(2, 2)
(2, 3)
(2, 4)
(3, 4)
(4, 4)
#include<cstdio>
#include<cstring>
#include<queue>
#include<iostream>
using namespace std;

int vis[6][6];
int mp[6][6];
int d[4][2] = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}};

struct node{
    int x, y;
};

node pre[6][6];

void print(){//逆序输出
    node lu[100];
    int i = 0;
    lu[i].x = lu[i].y = 4;
    //printf("(%d, %d)\n", lu[i].x, lu[i].y);
    for(;;){
        if(lu[i].x == 0 && lu[i].y == 0)
            break;
        else{
            lu[i+1] = pre[lu[i].x][lu[i].y];
        }
        i++;
    }
   // cout << "i = " << i << endl;
    while(i >= 0){
        printf("(%d, %d)\n", lu[i].x, lu[i].y);
        i--;
    }
}

void bfs(){
    queue<node> q;
    node a, ne;
    vis[0][0] = 1;
    q.push(node{0, 0});
    while(!q.empty()){
        a = q.front();
        q.pop();
        if(a.x == 4 && a.y == 4){
            print();
            return ;
        }
        for(int i = 0; i < 4; i++){
            ne.x = a.x + d[i][0];
            ne.y = a.y + d[i][1];
            if(!vis[ne.x][ne.y] && ne.x >=0 && ne.y >= 0 && ne.x < 5 && ne.y < 5 && mp[ne.x][ne.y] != 1){
                q.push(ne);
                //cout << "ne.x = " << ne.x << " ne.y = " << ne.y << endl;
                pre[ne.x][ne.y] = a;
                //cout << "pre.x = " << pre[ne.x][ne.y].x << " pre.y = " << pre[ne.x][ne.y].y << endl;
                vis[ne.x][ne.y] = 1;
            }
        }
    }
}

int main(){
    for(int i = 0; i < 5; i++){
        for(int j = 0; j < 5; j++){
            scanf("%d", &mp[i][j]);
        }
    }
    memset(vis, 0, sizeof(vis));
    bfs();
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值