PAT (Advanced Level) Practice 1008 Elevator (20 分) 凌宸1642

PAT (Advanced Level) Practice 1008 Elevator (20 分) 凌宸1642

题目描述:

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

译:我们城市最高的建筑只有一部电梯。一个请求列表由 N个正整数组成。这些数字表示电梯将会在哪些指定楼层停靠。电梯上升一层花费 6秒 的时间,电梯下降一层花费 4 秒的时间。电梯每次停靠会停留 5秒的时间


Input Specification (输入说明):

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

译:每个输入文件包含一个测试用例,每个用例包含一个整数 N , 紧跟着后面的是 N 个正整数。输入所有的数字都小于 100.


Output Specification (输出说明):

For each test case, print the total time on a single line.

译:对于每个测试用例,在一行中输出耗费时间的总和。


Sample Input (样例输入):

3 2 3 1

Sample Output (样例输出):

41

The Idea:

首先,有 N 个数据意味着需要停留 N 次,所以可以直接算出停留的时间就是 N * 5 , 然后再遍历列表中的所有数,如果是上升,结果就加上 楼层差乘以 6 秒,如果是下降,结果就加上 楼层差乘以 4 秒, 遍历结束,得到的总和就是答案。


The Codes:

#include<bits/stdc++.h>
using namespace std ;
#define MAX 110
int ele[MAX] = { 0 } ;
int main(){
	int n , sum , t ;
	scanf("%d" , &n) ;
	sum = n * 5 ; // 所有的停靠时间
	for(int i = 1 ; i <= n ; i ++) scanf("%d" , &ele[i]) ;
	for(int i = 1 ; i <= n ; i ++){
		if(ele[i] > ele[i - 1]) sum += (ele[i] - ele[i - 1]) * 6 ;  // 加上上升的时间
		else sum += (ele[i - 1] - ele[i]) * 4 ; // 加上下降的时间
	}
	printf("%d\n" , sum) ;
	return 0 ;
}

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

lingchen0522

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值