PAT (Advanced Level) Practice 1041 Be Unique (20 分) 凌宸1642

PAT (Advanced Level) Practice 1041 Be Unique (20 分) 凌宸1642

题目描述:

Being unique is so important to people on Mars that even their lottery is designed in a unique way. The rule of winning is simple: one bets on a number chosen from [1,10 4 ]. The first one who bets on a unique number wins. For example, if there are 7 people betting on { 5 31 5 88 67 88 17 }, then the second one who bets on 31 wins.

译:对于火星人来说,成为唯一是很重要的,甚至他们的彩票也是以独特的方式设计的。获胜的规则很简单,对从 区间[1 , 10 4 ] 中选择的一个数字下注。第一个在唯一号码上下注的人就赢了。例如,如果有7个人对{5 31 5 88 67 88 17} 下注,那么第二个下注 31 的人赢。


Input Specification (输入说明):

Each input file contains one test case. Each case contains a line which begins with a positive integer N (≤10 5 ) and then followed by N bets. The numbers are separated by a space.

译:每个输入文件包含一个测试用例,每个用例在一行中包含一个正整数 N (≤10 5 ) , 紧跟着 N 个赌注。所有的数字被一个空格分隔。


Output Specification (输出说明):

For each test case, print the winning number in a line. If there is no winner, print None instead.

译:对于每个测试用例,在一个行中输出获胜的数字。如果没有获胜者,则输出 None


Sample Input 1 (样例输入1):

7 5 31 5 88 67 88 17

Sample Output 1 (样例输出1):

31

Sample Input 2 (样例输入2):

5 888 666 666 888 888

Sample Output 2 (样例输出2):

None

The Idea:

签到题,真的是签到的水题。直接用 map 存储每个数字出现的顺序,然后再遍历数字,判断第一个只出现一次的数字,就是 winner 。 遍历完整个序列之后,如果没有找到只出现一次的数字,则输出 None


The Codes:

#include<bits/stdc++.h>
using namespace std;
int num[100010] , n ; 
map<int , int > mp ;
int main(){
	cin >> n ;
	for(int i = 0 ; i < n ; i ++){
		cin >> num[i] ;
		mp[num[i]] ++ ; // 该数字出现的顺序加 1 
	}
	for(int i = 0 ; i < n ; i ++){
		if(mp[num[i]] == 1){
			cout << num[i] << endl ;
			break; 
		}
		if(i == n - 1) cout << "None" << endl ;
	}
	return 0 ;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 1
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

lingchen0522

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值