【笨方法学PAT】1005 Spell It Right(20 分)

一、题目

Given a non-negative integer N, your task is to compute the sum of all the digits of N, and output every digit of the sum in English.

Input Specification:

Each input file contains one test case. Each case occupies one line which contains an N (≤10​100​​).

Output Specification:

For each test case, output in one line the digits of the sum in English words. There must be one space between two consecutive words, but no extra space at the end of a line.

Sample Input:

12345

Sample Output:

one five

二、题目大意

给一个数字,求各位数字之和 sum,输出 sum 各个位上的数字对应的英文。

三、考点

string

PS. string 与 int 的互相转换,可以参考:【笨方法学PAT】string 与 int 的互相转换

四、解题思路

1、将每个数字对应的英文单词保存到 string 数组中;

2、string 读入(10^1000次方);

3、求和,int 类型

4、将和转为string;

5、遍历string输出。

【注意】PAT对数字的各种“奇奇怪怪”的处理,转为 string 比较合适!

五、代码

#include<iostream>
#include<string>
using namespace std;
int main() {
	string eng[10] = { "zero","one","two","three","four","five","six","seven","eight","nine"};
	string s;
	cin >> s;
	int sum = 0;
	//求和
	for (int i = 0; i < s.length(); ++i)
		sum += s[i] - '0';

	//输出
	string t = to_string(sum);
	for (int i = 0; i < t.length(); ++i) {
		if (i != 0)
			cout << " ";
		cout << eng[t[i] - '0'];
	}

	system("pause");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值