【笨方法学PAT】1019 General Palindromic Number (20 分)

一、题目

A number that will be the same when it is written forwards or backwards is known as a Palindromic Number. For example, 1234321 is a palindromic number. All single digit numbers are palindromic numbers.

Although palindromic numbers are most often considered in the decimal system, the concept of palindromicity can be applied to the natural numbers in any numeral system. Consider a number N>0 in base b≥2, where it is written in standard notation with k+1 digits a​i​​ as ∑​i=0​k​​(a​i​​b​i​​). Here, as usual, 0≤a​i​​<b for all i and a​k​​ is non-zero. Then N is palindromic if and only if a​i​​=a​k−i​​ for all i. Zero is written 0 in any base and is also palindromic by definition.

Given any positive decimal integer N and a base b, you are supposed to tell if N is a palindromic number in base b.

Input Specification:

Each input file contains one test case. Each case consists of two positive numbers N and b, where 0<N≤10​9​​ is the decimal number and 2≤b≤10​9​​ is the base. The numbers are separated by a space.

Output Specification:

For each test case, first print in one line Yes if N is a palindromic number in base b, or No if not. Then in the next line, print N as the number in base b in the form "a​k​​ a​k−1​​ ... a​0​​". Notice that there must be no extra space at the end of output.

Sample Input 1:

27 2

Sample Output 1:

Yes

1 1 0 1 1

Sample Input 2:

121

5

Sample Output 2:

No

4 4 1

二、题目大意

进制转化,转化后的结果是否是回文。

注意:进制的大小可能很大,求进制过程中获得的每一位可能>9,使用数组保存;同时,需要一个变量维护转化后数组的长度。

三、考点

进制转换

四、解题思路

1、读取数字,对0特别处理(对于一些边界条件等特殊条件,直接处理掉,方便之后);

2、进制转换,保存到数组中,并使用变量维护数组的长度(也可以使用vector,之后push_back());

3、判断回文,输出结果。

五、代码

#include<iostream>
#include<string>
#include<algorithm>
#define N 10001
using namespace std;
int a[N];
int m = 0;
//进制转化,保存到数组中
void toBase(int n,int b) {
	while (n != 0) {
		a[m] = n%b;
		n = n / b;
		m++;
	}
}
int main() {
	//读入数据
	int n, b;
	cin >> n >> b;

	//对0特别处理
	if (n == 0) {
		cout << "Yes" << endl;
		cout << 0;
		return 0;
	}

	//判断是否回文
	toBase(n, b);
	bool flag = true;
	for (int i = 0; i < m / 2; ++i) {
		if (a[i] != a[m - i - 1]) {
			flag = false;
			break;
		}
	}

	//输出结果
	if (flag == false)
		cout << "No" << endl;
	else
		cout << "Yes" << endl;
	for (int i = m-1; i >=0 ; --i) {
		if (i != m-1)
			cout << " ";
		cout << a[i];
	}
	system("pause");
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值