【笨方法学PAT】1107 Social Clusters (30 分)

一、题目

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

二、题目大意

有n个人,每个人喜欢k个活动,如果两个人有任意一个活动相同,就称为他们处于同一个社交网络。求这n个人一共形成了多少个社交网络。

三、考点

并查集

四、注意

1、都是套路;

2、本题的难点在于将人按照爱好并查集,对人并查集,而不是对课程并查集

五、代码

#define _CRT_SECURE_NO_WARNINGS
#include<iostream>
#include<vector>
#include<algorithm>
#include<math.h>
#include<set>
#define N 10010
using namespace std;
int fa[N];

void init() {
	for (int i = 0; i < N; ++i)
		fa[i] = i;
}

int findFather(int x) {
	int a = x;
	while (x != fa[x])
		x = fa[x];
	while (a != fa[a])
	{
		int z = a;
		a = fa[a];
		fa[z] = x;
	}
	return x;
}
void unionFather(int a, int b) {
	int x = findFather(a);
	int y = findFather(b);
	if (x != y)
		fa[x] = y;
}

bool cmp(int a, int b) {
	return a > b;
}

int main() {
	//init
	init();

	//read
	int n;
	cin >> n;
	vector<int> hobby(N,0);
	int max_num =0;
	for (int i = 1; i <= n; ++i) {
		int m,a,b;
		scanf("%d:", &m);
		for (int j = 0; j < m; ++j) {
			cin >> b;
			if (hobby[b] == 0)
				hobby[b] = i;
			unionFather(i, hobby[b]);
		}
	}

	//trees
	vector<int> peo(n+1, 0);
	int num = 0;
	for (int i = 1; i <= n; ++i) {
		peo[findFather(i)]++;
	}
	for (int i = 1; i <= n; ++i) {
		if (peo[i] != 0)
			num++;
	}
	sort(peo.begin(), peo.end(), cmp);
	cout << num << endl;
	for (int i = 0; i < num; ++i) {
		if (i != 0)
			cout << " ";
		cout << peo[i];
	}

	system("pause");
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值