1107 Social Clusters (30 分)

1107 Social Clusters (30 分)

When register on a social network, you are always asked to specify your hobbies in order to find some potential friends with the same hobbies. A social cluster is a set of people who have some of their hobbies in common. You are supposed to find all the clusters.

Input Specification:

Each input file contains one test case. For each test case, the first line contains a positive integer N (≤1000), the total number of people in a social network. Hence the people are numbered from 1 to N. Then N lines follow, each gives the hobby list of a person in the format:

K​i​​: h​i​​[1] h​i​​[2] ... h​i​​[K​i​​]

where K​i​​ (>0) is the number of hobbies, and h​i​​[j] is the index of the j-th hobby, which is an integer in [1, 1000].

Output Specification:

For each case, print in one line the total number of clusters in the network. Then in the second line, print the numbers of people in the clusters in non-increasing order. The numbers must be separated by exactly one space, and there must be no extra space at the end of the line.

Sample Input:

8
3: 2 7 10
1: 4
2: 5 3
1: 4
1: 3
1: 4
4: 6 8 1 5
1: 4

Sample Output:

3
4 3 1

思路

  • 思路比较简单:
  • 并查集解决“朋友圈”的问题:假如已知有n个人和m对好友关系。如果两个人是直接或者间接的好友,则认为他们属于一个朋友圈,请写出程序求出这n个人里一共有多少个朋友圈。
  • course[i]表示第一个喜欢编号为i (1<=i<=1000)的爱好的人的id(1~N)
  • 则接下来再遇到喜欢该项爱好的人直接划为与上述course[i]同一个圈子——Union
  • isRoot[i]表示以i为根节点的圈子的人数,通过FindRoot()遍历每一个id,则可以找到以任一id为根节点的圈子的人数
#include <bits/stdc++.h>
using namespace std;

const int maxn = 1010;
int pre[maxn];
int course[maxn] = {0};
int isRoot[maxn] = {0}; //表示i作为根节点的圈子有多少人

//非路径压缩版
int FindRoot(int x)
{
    if(x == pre[x]) return x;
    else return pre[x] = FindRoot(pre[x]);
}

void Union(int x, int y)
{
    int rx = FindRoot(x);
    int ry = FindRoot(y);
    if(rx != ry){
        pre[rx] = ry; //或pre[ry]=rx
    }
}

void Init(int n)
{
    for(int i = 1; i <= n; ++i){
        pre[i] = i;
    }
}

bool cmp(int x, int y){
    return x > y;
}

int main()
{
    int n, k, h;
    scanf("%d",&n);
    Init(n);
    for(int i = 1; i <= n; ++i){
        scanf("%d:",&k);
        for(int j = 0; j < k; ++j){
            scanf("%d",&h);
            if(course[h] == 0)
                course[h] = i;
            else Union(i, FindRoot(course[h]));
        }
    }
    for(int i = 1; i <= n; ++i){
        isRoot[FindRoot(i)]++;
    }
    int ans = 0;
    for(int i = 1; i <= n; ++i){
        if(isRoot[i] != 0) ans++;
    }
    printf("%d\n",ans);
    sort(isRoot + 1, isRoot + n + 1, cmp);//注意sort范围 
    for(int i = 1; i <= ans; ++i){
        if(i != 1) printf(" ");
        printf("%d",isRoot[i]);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值