Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):
an Stan wins.
25 7 11 7 4 7 4 3 1 3 1 0
an Stan wins.
Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.
Sample Input
34 12 15 24 0 0
Sample Output
Stan wins Ollie wins
Source
一看就是博弈= =~ 但又不是常见的~…… 分析:每次都是从较大值中取出较小的整数倍~ 如a,b两个数(规定a<b,
a>b时,swap(a,b)~),有3种情况,a<b/2…… b%a==0……a==0~ 这三个可以知道胜负。如果a>b/2时,令b=b-a~,继续以上步骤,总会导出哪三种情况之一。此时,需要用一个bool来储存b=b-a的次数。虽然用int也可以,但bool的0、1两种状态足够了。先假设bool=1~,每进行一次b=b-a~,bool=!bool…… 当a,b满足三个判别套件之一时,判断bool真假…… 为真时,Stan赢,为假时Olie赢……
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <cctype>
#include <stack>
using namespace std;
int main(){
int a,b;
while(cin>>a>>b){
if(a==0 && b==0)
break;
bool judge=1;
while(1){
if(a>b)
swap(a,b);
if(a<b/2 || b%a==0 || a==0){
if(judge){
cout<<"Stan wins"<<endl;
break;
}
else{
cout<<"Ollie wins"<<endl;
break;
}
}
b=b-a;
judge=!judge;
}
}
}
#include <algorithm>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <cctype>
#include <stack>
using namespace std;
int main(){
int a,b;
while(cin>>a>>b){
if(a==0 && b==0)
break;
bool judge=1;
while(1){
if(a>b)
swap(a,b);
if(a<b/2 || b%a==0 || a==0){
if(judge){
cout<<"Stan wins"<<endl;
break;
}
else{
cout<<"Ollie wins"<<endl;
break;
}
}
b=b-a;
judge=!judge;
}
}
}