HDU - 1525 Euclid's Game (找规律)

Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):

25 7
11 7
4 7
4 3
1 3
1 0

an Stan wins.

Input

The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.

Output

For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.

Sample Input

34 12
15 24
0 0

Sample Output

Stan wins
Ollie wins

题意:

给出两个数a,b,每次操作,大的数减掉小的数的整数倍。一个数变为0 的时候结束。先把其中一个数减为0的获胜。Stan固定先手,输出赢的人。

题解:

假设 a>=b

如果a==b 或者说 a%b==0 也就是a是b的倍数,那么肯定先手获胜。

如果 a>=2*b 那么当前那个人肯定知道 (b,a%b) 是必胜态还是必败态。如果是必败态,先手将a,b变成(b,a%b),那么先手肯定赢。如果是必胜态,先手将a,b变成(a%b+b,b),那么对手只有将这两个数变成(b,a%b),先手获胜。也就是说 a >=2*b 时先手必胜。

如果是b<a<2*b  那么只有一条路:变成 (b,a%b)这样一直下去看谁先面对上面的必胜状态。

所以假如面对 b<a<2*b 的状态,就先走下去。直到面对一个 a%b==0 || a >=2*b 的状态。

代码:

#include <cstdio>
#include <algorithm>

using namespace std;

int main(){
	
	int A,B;
	while(scanf("%d %d",&A,&B) && (A||B)){
		if(A < B)swap(A,B);
		bool flag = true;
		while(1){
			if(A%B==0 || A/B>=2)break;
			else {
				int t = A;
				A = A % B;
				swap(A,B);
				flag = !flag;
			}
		}
		if(flag)printf("Stan wins\n");
		else printf("Ollie wins\n");
	}
	
	return 0;
} 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值