HDU_1161 Eddy's mistakes

Eddy's mistakes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6147    Accepted Submission(s): 3487


Problem Description
Eddy usually writes articles ,but he likes mixing the English letter uses, for example "computer science" is written frequently "coMpUtEr scIeNce" by him, this mistakes lets Eddy's English teacher be extremely discontentment.Now please you to write a procedure to be able in the Bob article English letter to turn completely the small letter. 
 

Input
The input contains several test cases.each line consists a test case,Expressed Eddy writes in an article , by letter, blank space,numeral as well as each kind of punctuation
composition, the writing length does not surpass 1000 characters.
 

Output
For each test case, you should output an only line, after namely the result of transforms the lowercase letter.
 

Sample Input
  
  
weLcOmE tO HDOj Acm 2005!
 

Sample Output
  
  
welcome to hdoj acm 2005!
 

Author
eddy
 

Recommend
JGShining
 

CODE:


#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main()
{
char s[1000];
while(gets(s))
{
int i,len;
len=strlen(s);
for(i=0;i<len;i++)
s[i]=tolower(s[i]);
puts(s);
}
return 0;
}


采用大小写转换函数,简单!
大小写转换函数:
头文件#include<stdlib.h> 或者#include<ctype.h>
小写变大写:s[i]=toupper(s[i]),s为字符数组;
大写变小写:s[i]=tolower(s[i]).
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值