hdu_oj1161Eddy‘s mistakes(水题)

Eddy's mistakes

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 15827    Accepted Submission(s): 8649


 

Problem Description
Eddy usually writes articles ,but he likes mixing the English letter uses, for example "computer science" is written frequently "coMpUtEr scIeNce" by him, this mistakes lets Eddy's English teacher be extremely discontentment.Now please you to write a procedure to be able in the Bob article English letter to turn completely the small letter. 
 

 

Input
The input contains several test cases.each line consists a test case,Expressed Eddy writes in an article , by letter, blank space,numeral as well as each kind of punctuation
composition, the writing length does not surpass 1000 characters.
 

 

Output
For each test case, you should output an only line, after namely the result of transforms the lowercase letter.
 

 

Sample Input
 
weLcOmE tO HDOj Acm 2005!
 

 

Sample Output
 
welcome to hdoj acm 2005!

 

水题,大写全部转换为小写,主要是熟悉一下gets()这样可以读入空格的操作

上ac代码

#include <iostream>
#include <string>
#include <cstring>
#include <cstdio>
using namespace std;
int main()
{
    char str[100010];
    while(gets(str))
    {
        for(int i=0;i<strlen(str);i++)
        {
            if((int)str[i]>=65&&(int)str[i]<=91)
                str[i]=str[i]+32;
        }
        cout<<str<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值