Problem1003


/**
* Description
* How far can you make a stack of cards overhang a table?
* If you have one card, you can create a maximum overhang of half a card length.
* (We're assuming that the cards must be perpendicular to the table.)
* With two cards you can make the top card overhang the bottom one by half a card length,
* and the bottom one overhang the table by a third of a card length,
* for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths.
* In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + ... + 1/(n + 1) card lengths,
* where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3,
* the third overhangs the fourth by 1/4, etc.,
* and the bottom card overhangs the table by 1/(n + 1).
* This is illustrated in the figure below.
*
* Input
* The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input.
* Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20;
* c will contain exactly three digits.
*
* Output
* For each test case,
* output the minimum number of cards necessary to achieve an overhang of at least c card lengths.
* Use the exact output format shown in the examples.
*
* Sample Input
* 1.00
* 3.71
* 0.04
* 5.19
* 0.00
*
* Sample Output
* 3 card(s)
* 61 card(s)
* 1 card(s)
* 273 card(s)
*/


import java.io.BufferedReader;
import java.io.IOException;
import java.io.InputStreamReader;

public class Main {
public static void main(String[] args) {
BufferedReader br = new BufferedReader(new InputStreamReader(System.in));
String s;
try {
while (!"0.00".equals(s = br.readLine())) {
double d = Double.parseDouble(s);
//仅1张card时长度为2/1,因此以其为第一个底数,递增直到大于需要的长度
double count = 2;
while((d-=1/count)>0){
count ++;
}
System.out.println((int)(count-1)+" card(s)");
}
} catch (Exception e) {
e.printStackTrace();
}
}
}



题目大意:说在桌子边上叠卡片能叠多长;只有一张卡片的时候,它可以有1/2的长度伸出来;两张卡片的话,叠在下面的就只能伸出1/3了,上面的那张依旧是露出1/2……
也就是求1/2+1/3+1/4+……1/n的了,上面用的方法嘛 :oops: 没啥技术含量的,不过结果还是能出来,嘿嘿,我的目标还是accept就行
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值