暑假集训第二周——贪心 A - Radar Installation雷达装置


A - Radar Installation
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 

Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1
分析:

贪心算法大致分为区间选点,区间覆盖,选择不相交区间


本题虽然看着比较复杂,无从下手,但其实他可以转化为直线区间选点,


用直角三角形的思想把坐标选取转化为X轴上的选择区间,如果区间不能相交就要再加一个雷达装置


贪心的题目如果排序一般都是按照结束的大小顺序排,不用考虑太多,学会运用标记,可以解决很多特殊值


1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct S
{
    double x,y;
} a[1010];
int cmp(S a,S b)
{
  
        return a.y<b.y;
}
int main()
{

    int n,i,j=1,s,c;
    double d,m,t;
    while(scanf("%d %lf",&n,&d)&&n+d)
    {
        s=1,c=0;
        for(i=0; i<n; i++)
        {
            scanf("%lf %lf",&m,&t);
            if(t>d||t<-d)
                c=1;
            a[i].x=m-sqrt(d*d-t*t);
            a[i].y=m+sqrt(d*d-t*t);
        }
        sort(a,a+n,cmp);
        double k=a[0].y;
        for(i=1; i<n; i++)
            if(a[i].x>k)
            {
                s++;
                k=a[i].y;
            }
        if(c==1)
        {
            s=-1;
            c=0;
        }
        printf("Case %d: %d\n",j++,s);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值