606第十周周六赛E - Nested Dolls 套玩具



E - Nested Dolls
Time Limit:1000MS     Memory Limit:32768KB     64bit IO Format:%I64d & %I64u

Description

Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements? 
 

Input

On the first line of input is a single positive integer 1 <= t <= 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 <= m <= 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, . . . ,wm, hm, where wi is the width and hi is the height of doll number i. 1 <= wi, hi <= 10000 for all i. 
 

Output

For each test case there should be one line of output containing the minimum number of nested dolls possible. 
 

Sample Input

     
     
4 3 20 30 40 50 30 40 4 20 30 10 10 30 20 40 50 3 10 30 20 20 30 10 4 10 10 20 30 40 50 39 51
 

Sample Output

     
     
1 2 3 2

动态规划和贪心结合,求一个递增最长子序列

宽度从大到小排,长度从小向大排,用到一个函数,注意理解

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
const int  INF=0x7fffffff;
struct doll
{
    int h,w;
} s[20010];
int cmp(doll x,doll y)
{
    if(x.w!=y.w)
        return x.w>y.w;
    else
        return  x.h<y.h;
}
int main()
{
    int m,n,i,j,g[20010];
    scanf("%d",&n);
    while(n--)
    {
        j=0;
        scanf("%d",&m);
        for(i=1; i<=m; i++)
            g[i]=INF;
        for(i=0; i<m; i++)
            scanf("%d%d",&s[i].w,&s[i].h);
        sort(s,s+m,cmp);
        for(i=0; i<m; i++)
        {
            int  k=lower_bound(g+1,g+m+1,s[i].h)-g;
            while(g[k]==s[i].h)
                k++;
            g[k]=s[i].h;
            j=max(j,k);
        }
        printf("%d\n",j);
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值