AYITACM2016省赛第二周 H(最长公共子序列)



Input
Input consists of pairs of lines. The first line of a pair contains the first string and the second line
contains the second string. Each string is on a separate line and consists of at most 1,000 characters
Output
For each subsequent pair of input lines, output a line containing one integer number which satisfies the
criteria stated above.
Sample Input
bcacbcabbaccbab
bccabccbbabacbc
a1b2c3d4e
zz1yy2xx3ww4vv
abcdgh
aedfhr
abcdefghijklmnopqrstuvwxyz
a0b0c0d0e0f0g0h0i0j0k0l0m0n0o0p0q0r0s0t0u0v0w0x0y0z0
abcdefghijklmnzyxwvutsrqpo
opqrstuvwxyzabcdefghijklmn
Sample Output
11
4
3
26
14

分析:题意很简单,就是找到两个字符串的最长公共子序列,就是没有注意到字符创中可能有空格,不能用scanf()导致提交错了很多次


#include<stdio.h>
#include<string.h>
char a[1100],b[1100];
int s[1100][1100];
int main()
{
    int i,j,a1,b1;
    while(gets(a+1),gets(b+1))
    {
        //不能用scanf,因为字符串中可能有空格
        memset(s,0,sizeof(s));//初始化数组
        a1=strlen(a+1);
        b1=strlen(b+1);
        for(i=1; i<=a1; i++)
            for(j=1; j<=b1; j++)
                if(a[i]==b[j]) //如果字符相等,就等于目前相等次数加一
                    s[i][j]=s[i-1][j-1]+1;
                else //如果不相等,就判断哪个字符串与另外一个相等的多
                    s[i][j]=s[i-1][j]>s[i][j-1]?s[i-1][j]:s[i][j-1];
        printf("%d\n",s[a1][b1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值