AYITACM2016省赛第三周 G - Unidirectional TSP(DP单向旅行商问题)

Description

Download as PDF

Background

Problems that require minimum paths through some domain appear in many different areas of computer science. For example, one of the constraints in VLSI routing problems is minimizing wire length. The Traveling Salesperson Problem (TSP) -- finding whether all the cities in a salesperson's route can be visited exactly once with a specified limit on travel time -- is one of the canonical examples of an NP-complete problem; solutions appear to require an inordinate amount of time to generate, but are simple to check.

This problem deals with finding a minimal path through a grid of points while traveling only from left to right.

The Problem

Given an tex2html_wrap_inline352 matrix of integers, you are to write a program that computes a path of minimal weight. A path starts anywhere in column 1 (the first column) and consists of a sequence of steps terminating in column n (the last column). A step consists of traveling from column i to column i+1 in an adjacent (horizontal or diagonal) row. The first and last rows (rows 1 and m) of a matrix are considered adjacent, i.e., the matrix ``wraps'' so that it represents a horizontal cylinder. Legal steps are illustrated below.

picture25

The weight of a path is the sum of the integers in each of the n cells of the matrix that are visited.

For example, two slightly different tex2html_wrap_inline366 matrices are shown below (the only difference is the numbers in the bottom row).

picture37

The minimal path is illustrated for each matrix. Note that the path for the matrix on the right takes advantage of the adjacency property of the first and last rows.

The Input

The input consists of a sequence of matrix specifications. Each matrix specification consists of the row and column dimensions in that order on a line followed by tex2html_wrap_inline376 integers where m is the row dimension and n is the column dimension. The integers appear in the input in row major order, i.e., the first n integers constitute the first row of the matrix, the second n integers constitute the second row and so on. The integers on a line will be separated from other integers by one or more spaces. Note: integers are not restricted to being positive. There will be one or more matrix specifications in an input file. Input is terminated by end-of-file.

For each specification the number of rows will be between 1 and 10 inclusive; the number of columns will be between 1 and 100 inclusive. No path's weight will exceed integer values representable using 30 bits.

The Output

Two lines should be output for each matrix specification in the input file, the first line represents a minimal-weight path, and the second line is the cost of a minimal path. The path consists of a sequence of n integers (separated by one or more spaces) representing the rows that constitute the minimal path. If there is more than one path of minimal weight the path that is lexicographically smallest should be output.

Sample Input

5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 8 6 4
5 6
3 4 1 2 8 6
6 1 8 2 7 4
5 9 3 9 9 5
8 4 1 3 2 6
3 7 2 1 2 3
2 2
9 10 9 10

Sample Output

1 2 3 4 4 5
16
1 2 1 5 4 5
11
1 1
19
分析:

给定一个n*m的矩阵,从第一列的任何一个位置出发,到最后一列的任何一个位置终止,每一次只能往下一列走,走直线或者对角线,求出最小权值,以及打印字典序最小路径。

只要能把复杂度降下来的就叫动态规划,状态转移只有三种情况,向左,向左上,向左下,用数组存储状态变化。

#include<stdio.h>
#include<string.h>
#include<algorithm>
#define INF 0x3f3f3f3f;
using namespace  std;
int main()
{
    int map[12][102],p[12][102],s[102];
    int m,n,i,j;
    while(scanf("%d%d",&m,&n)!=EOF)
    {
        memset(p,-1,sizeof(p));
        for(i=1; i<=m; i++)
            for(j=1; j<=n; j++)
                scanf("%d",&map[i][j]);
        for(j=n-1; j>=1; j--)  //因为要输出路径,所以可以逆序循环
            for(i=1; i<=m; i++)
            {
                int b=i,a,c,d,e=-1;//a,b,c为向左上,左,左下
                if(i>=2) a=i-1;//当行号大于1时,可以向上走
                else  a=m;    //如果等一,可以跳到最后一行
                if(i<m) c=i+1;//如果行号小于m,可以向下走
                else  c=1;//如果等于m,可以跳回第一行
                d=min(min(map[a][j+1],map[b][j+1]),map[c][j+1]);
                map[i][j]+=d; //寻找三种情况下最小的一个数据
                if(d==map[a][j+1])//寻找字典序最小的数据
                    e=a;
                if(d==map[b][j+1]&&(e==-1||(e!=-1&&b<e)))
                    e=b;
                if(d==map[c][j+1]&&(e==-1||(e!=-1&&c<e)))
                    e=c;
                p[i][j]=e;//前一个数据的行号
            }
        int flag=0,sum=INF;
        for(i=1; i<=m; i++) //从第一列寻找最小路径
            if(map[i][1]<sum)
            {
                sum=map[i][1];
                flag=i; //第一列为第i行的数据
            }
        printf("%d",flag);
        flag=p[flag][1];  //输出路径
        for(i=2; i<=n&&flag!=-1; i++)
        {
            printf(" %d",flag);
            flag=p[flag][i];  //通过数组寻找下一个行号
        }
        printf("\n%d\n",sum);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值