AYITACM2016省赛第三周A-Nested Dolls(贪心解嵌套问题)

Description

Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements? 
 

Input

On the first line of input is a single positive integer 1 <= t <= 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 <= m <= 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, . . . ,wm, hm, where wi is the width and hi is the height of doll number i. 1 <= wi, hi <= 10000 for all i. 
 

Output

For each test case there should be one line of output containing the minimum number of nested dolls possible. 
 

Sample Input

    
    
4 3 20 30 40 50 30 40 4 20 30 10 10 30 20 40 50 3 10 30 20 20 30 10 4 10 10 20 30 40 50 39 51
 

Sample Output

    
    
1 2 3 2
分析:

  先按照 w 从大到小排序可以理解为把小的嵌套到大的当中去,对于 x相同时 y 从小到大排序,如果 m 个 x 相同, 那么必然是嵌套在 m 个不同的娃娃中,可能是比它大的,也可能是它本身,先选择 y 最小的嵌入到前面能够满足条件的娃娃中,再新用一个娃娃嵌套 y 倒数第二小的娃娃,那么这时嵌套了第二个娃娃的东西,一定能比已经嵌套了第一个的更能嵌套其它的娃娃 x 相同 ,而 y 更优;

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct qujian
{
    int x,y;
} a[25100],b[25000];
int cmp(qujian A,qujian B)
{
    if(A.x!=B.x) //长从大到小
        return A.x>B.x;
    else//宽从小到大,保证剩余最少的娃娃
        return A.y<B.y;
}
int main()
{
    int m,n,i,j,k,t;
    scanf("%d",&n);
    while(n--)
    {
        t=0;
        scanf("%d",&m);
        for(i=0; i<m; i++)
        {
            scanf("%d%d",&a[i].x,&a[i].y);//输入娃娃的长和宽
            b[i].x=b[i].y=11000;  //首先假设所有的娃娃都可以嵌套
        }
        sort(a,a+m,cmp);
        for(i=0; i<m; i++)
        {
            j=0;
            while(b[j].x<=a[i].x||b[j].y<=a[i].y)
                j++;    //如果嵌套不进去,就要再重新开始一个娃娃
            b[j].x=a[i].x;  //不断更新为当前嵌套的最小的娃娃
            b[j].y=a[i].y;
        }
        k=0;
        for(i=0; i<m; i++)
            if(b[i].x!=11000) //因为题中给出的娃娃的长最长为10000
                k++;
        printf("%d\n",k);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值