Nested Dolls HDU - 1677 (矩形嵌套问题,先构造序列,再用upper_bound找最长上升子序列+贪心)

Dilworth is the world’s most prominent collector of Russian nested dolls: he literally has thousands of them! You know, the wooden hollow dolls of different sizes of which the smallest doll is contained in the second smallest, and this doll is in turn contained in the next one and so forth. One day he wonders if there is another way of nesting them so he will end up with fewer nested dolls? After all, that would make his collection even more magnificent! He unpacks each nested doll and measures the width and height of each contained doll. A doll with width w1 and height h1 will fit in another doll of width w2 and height h2 if and only if w1 < w2 and h1 < h2. Can you help him calculate the smallest number of nested dolls possible to assemble from his massive list of measurements? 
InputOn the first line of input is a single positive integer 1 <= t <= 20 specifying the number of test cases to follow. Each test case begins with a positive integer 1 <= m <= 20000 on a line of itself telling the number of dolls in the test case. Next follow 2m positive integers w1, h1,w2, h2, . . . ,wm, hm, where wi is the width and hi is the height of doll number i. 1 <= wi, hi <= 10000 for all i. 
OutputFor each test case there should be one line of output containing the minimum number of nested dolls possible. 
Sample Input
4
3
20 30 40 50 30 40
4
20 30 10 10 30 20 40 50
3
10 30 20 20 30 10
4
10 10 20 30 40 50 39 51
Sample Output
1
2
3
2

题意:输入n,有n个矩形,下面一行是长和宽,矩形嵌套问题,最少能嵌套成几个矩形,大的能套小的;

思路:刚开始想到了贪心,但是看了数据,一下子就否决了,我有想了想,是不是dp啊,我先排序,按长从大到小排序,要是有相等的,按宽从小到大排序(仔细想想为什么这样排序),自己构造出来了,自己想要的序列了,就开始遍历,有upper_bound找dp数组中第一个大于它的数,那么这个矩形一定能嵌套现在这个矩形(而且是第一个大于它的数),最后看看这个dp数组被插入的数有多长,也就最长上升子序列,就是最终嵌套成了几个矩形;

代码:

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
#define Max 20020
#define INF 0x3f3f3f3f
int dp[Max];
struct node
{
	int x,y;
}stu[Max];

int cmp(node a,node b)
{
	if(a.x==b.x)
		return a.y<b.y;
	else return a.x>b.x;
}

int main() 
{
	int i,j,t,n;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d",&n);
		for(i = 0;i<n;i++)
			scanf("%d%d",&stu[i].x,&stu[i].y);
		sort(stu,stu+n,cmp);
		memset(dp,INF,sizeof(dp));
		
		for(i = 0;i<n;i++)
		{
			int k = upper_bound(dp,dp+(n+1),stu[i].y) - dp;
			dp[k] = stu[i].y;
		}
		printf("%d\n",lower_bound(dp,dp+n,INF)-dp);
	}
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值