nyoj 308 substring (最长逆序字符串)

Substring

时间限制: 1000 ms  |  内存限制: 65535 KB
难度: 1
描述

You are given a string input. You are to find the longest substring of input such that the reversal of the substring is also a substring of input. In case of a tie, return the string that occurs earliest in input. 

Note well: The substring and its reversal may overlap partially or completely. The entire original string is itself a valid substring . The best we can do is find a one character substring, so we implement the tie-breaker rule of taking the earliest one first.

输入
The first line of input gives a single integer, 1 ≤ N ≤ 10, the number of test cases. Then follow, for each test case, a line containing between 1 and 50 characters, inclusive. Each character of input will be an uppercase letter ('A'-'Z').
输出
Output for each test case the longest substring of input such that the reversal of the substring is also a substring of input
样例输入
3                   
ABCABA
XYZ
XCVCX
样例输出
ABA
X
XCVCX
分析:

此题不是让求最长回文子串的,而是让求一个最长的子串,该子串的逆串也在原串中。举个例子来说,abcdba,若是求最长回文子串,应为a,对此题来说,应为ab,因为ab的逆串ba也在原串中。

#include<stdio.h>
#include<string.h>
char a[51],b[51],c[51][51];
int main()
{
    int t,i,j,l,m,k;
    scanf("%d%*c",&t);
    while(t--)
    {
        memset(c,0,sizeof(c));
        memset(b,0,sizeof(b));
        memset(a,0,sizeof(a));
        scanf("%s",a);
        l=strlen(a);
        for(i=l-1; i>=0; i--)
            b[l-1-i]=a[i];
        m=0,k=0;
        for(i=1; i<=l; i++)
            for(j=1; j<=l; j++)
                if(a[i-1]==b[j-1])
                {
                    c[i][j]=c[i-1][j-1]+1;
                    if(c[i][j]>m)
                    {
                        m=c[i][j];
                        k=i;
                    }
                }
        for(i=k-m; i<k; i++)
            printf("%c",a[i]);
        printf("\n");
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值