HDU 1503 Advanced Fruits (LCS最长公共子序列)

The company "21st Century Fruits" has specialized in creating new sorts of fruits by transferring genes from one fruit into the genome of another one. Most times this method doesn't work, but sometimes, in very rare cases, a new fruit emerges that tastes like a mixture between both of them. 
A big topic of discussion inside the company is "How should the new creations be called?" A mixture between an apple and a pear could be called an apple-pear, of course, but this doesn't sound very interesting. The boss finally decides to use the shortest string that contains both names of the original fruits as sub-strings as the new name. For instance, "applear" contains "apple" and "pear" (APPLEar and apPlEAR), and there is no shorter string that has the same property. 

A combination of a cranberry and a boysenberry would therefore be called a "boysecranberry" or a "craboysenberry", for example. 

Your job is to write a program that computes such a shortest name for a combination of two given fruits. Your algorithm should be efficient, otherwise it is unlikely that it will execute in the alloted time for long fruit names. 
Input
Each line of the input contains two strings that represent the names of the fruits that should be combined. All names have a maximum length of 100 and only consist of alphabetic characters. 

Input is terminated by end of file. 
Output
For each test case, output the shortest name of the resulting fruit on one line. If more than one shortest name is possible, any one is acceptable. 
Sample Input
apple peach
ananas banana
pear peach
Sample Output
appleach
bananas
pearch


分析:

题意:结合两个字符串,他们的公共子序列只输出一次。
 
题解:利用LCS算法标记字符,分别标记两串的公共字符,A串独有的字符,B串独有的字符。再利用递归函数才大到小遍历,从小到大回溯输出,既可以得到题意中要求的杂交串。
 
注意:样例数据的输出不一定要和样例输出一致,是满足题目要求的任意杂交串。

#include<stdio.h>
#include<string.h>
char a[1100],b[1100];
int dp[1100][1100],m[1100][1100];
void out(int x,int y)
{
    if(!x&&!y)
        return ;
   else if(m[x][y]==0)//如果相等,输出哪个都可以
   {
       out(x-1,y-1);
       printf("%c",a[x-1]);
   }
   else if(m[x][y]==1)//如果a字串独有,输出a字串字符
   {
       out(x-1,y);
       printf("%c",a[x-1]);
   }
   else if(m[x][y]==-1)//如果b字串长=独有,输出b字串字符
   {
       out(x,y-1);
       printf("%c",b[y-1]);
   }
}
int main()
{
    int i,j,a1,b1;
    while(scanf("%s%s",a,b)!=EOF)
    {
        memset(dp,0,sizeof(dp));//初始化数组
        a1=strlen(a);
        b1=strlen(b);
        for(i=0; i<a1; i++)//初始化m数组,从a数组到b数组0下标,都是a长
            m[i][0]=1;
        for(i=0; i<b1; i++)//初始化m数组,从b数组到a数组0下标,都是b长
            m[0][i]=-1;
        for(i=1; i<=a1; i++)
            for(j=1; j<=b1; j++)
                if(a[i-1]==b[j-1]) //如果字符相等,就等于目前相等次数加一
                {
                    dp[i][j]=dp[i-1][j-1]+1;
                    m[i][j]=0;//标记输出哪一个都可以
                }
                else if(dp[i-1][j]>=dp[i][j-1])
                {
                    dp[i][j]=dp[i-1][j];//更新最长字串
                    m[i][j]=1;//标记字符
                }
                else
                {
                  dp[i][j]=dp[i][j-1];
                  m[i][j]=-1;
                }
       out(a1,b1);
       printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值