HDU 1022 火车进出站

As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can't leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.

Input The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
Output The output contains a string "No." if you can't exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
Sample Input
3 123 321
3 123 312
Sample Output
Yes.
in
in
in
out
out
out
FINISH
No.
FINISH


#include<iostream>
#include<stdlib.h>
#include<stdio.h>
#include<cstring>
#include<string>
#include<stack>

using namespace std;

int main() {

	int num;
	string s1, s2;
	stack<int> q;
	while (cin >> num) {
		int flag = 0;

		cin >> s1 >> s2;
		int len1 = s1.length(), k = 0, i = 0;
		while (!q.empty())
				q.pop();
		while (1) {
			if (i < len1) {
				q.push(s1[i] - '0');
				i++;
			}
			while ((q.top() == (s2[k] - '0'))&&(k<len1)) {//要注意用while不是if 不断地将符合条件的车出站
                                q.pop();
				k++; 
				if(q.empty()) break;

			}



			if (i == len1 && q.empty()) {
				break;
			} else if (i == len1 && q.top() != s2[k] - '0') {
				cout << "No." << endl << "FINISH" << endl;
				flag = 1;
				break;
			}

		}


		if (flag == 0) {//其实就是上一个过程的重复,只是要输出状态。
			while (!q.empty())
				q.pop();
			i = k = 0;
			cout << "Yes." << endl;
			while (1) {
				if (i < len1) {
					q.push(s1[i] - '0');
					i++;
					cout << "in" << endl;
				}
				while ((q.top() == (s2[k] - '0'))&&(k<len1)) {
					q.pop();
					k++;
					cout << "out" << endl;
					if(q.empty()) break;
				}
				if (i == len1 && q.empty()) {
							 cout<<"FINISH"<<endl;
							 break;

						}

			}
		}
	}

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值