HDU 1021 Fibonacci Again

Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no
题意:对于输入的数字。计算f[n]是否能整除3;这道题的数据如果按照正常的方法计算,会特别大,所以需要一边计算一边处理数据。
思路:如果f[i]%3==0则在下一次的f[i+1]=f[i-1]+f[i]中,f[i]可以变为0;just soso。。。
#include<stdio.h>
#define N 1000000
int f[N];
int main()
{
     int n,i;
    f[0]=7;
    f[1]=11;
    while(scanf("%d",&n)!=EOF)
    {
    for(i=2;i<=n;i++)
    {
        f[i]=f[i-1]+f[i-2];
        if(f[i]%3==0)  
            f[i]=0;
        else
            f[i]=f[i]%3;
    }
    if(f[n]%3==0)
    {
        printf("yes\n");
    }
    else
    {
        printf("no\n");
    }

    }

    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值