HDU 1029 Ignatius and the Princess IV

Problem Description
"OK, you are not too bad, em... But you can never pass the next test." feng5166 says.

"I will tell you an odd number N, and then N integers. There will be a special integer among them, you have to tell me which integer is the special one after I tell you all the integers." feng5166 says.

"But what is the characteristic of the special integer?" Ignatius asks.

"The integer will appear at least (N+1)/2 times. If you can't find the right integer, I will kill the Princess, and you will be my dinner, too. Hahahaha....." feng5166 says.

Can you find the special integer for Ignatius?
 

Input
The input contains several test cases. Each test case contains two lines. The first line consists of an odd integer N(1<=N<=999999) which indicate the number of the integers feng5166 will tell our hero. The second line contains the N integers. The input is terminated by the end of file.
 

Output
For each test case, you have to output only one line which contains the special number you have found.
 

Sample Input
  
  
5 1 3 2 3 3 11 1 1 1 1 1 5 5 5 5 5 5 7 1 1 1 1 1 1 1
 

Sample Output
  
  
3 5 1

题意:给定一个序列,存在某个数的出现次数大于n/2;把这个数找出来。

思路:由于数列可以很长。所以按照正常的排序方法来解决时不可能通过的。

此题跟微软面试的一道题很像,我们先用count=0来标记temp是否变化。.用temp标记来最终的结果的那个数。如果i与i+1相等。则count++;如果不相等,count--;如果count==0时temp变化为当前的a[i];最后temp为结果数。总之,就是数字抵消,既然有某个数出现的次数大于n/2。抵消过后。剩下的数字一定为结果数。

#include<stdio.h>
#include<memory.h>
int a[1000000];
int main()
{
    int n;
    while(scanf("%d",&n)!=EOF)
    {
        int i;
        for(i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
        }
        int count=1;
        int temp=a[1];
        for(i=1;i<n;i++)
        {
            if(a[i+1]==temp)
            {
                count++;
            }
            else 
            {
                count--;
            }
            if(count==0)
            {
                count=1;
                temp=a[i+1];
            }
        }
        printf("%d\n",temp);
    }
    return 0;

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值